Dynamo 0.8.2 Stable Release is now available!

We have released Dynamo 0.8.2. Details about the great new features in the release are available here: http://dynamobim.com/dynamo082/

The auto-updater should be downloading the release for you automatically or else you can go to the Downloads page on this site: http://dynamobim.com/download/

Thank you everyone for your help testing it in the daily builds and the release candidates.

Node2Code ! Great update!

Thanks a lot Dynamo guys! Node2Code is super cool!

Couldn’t figure out how to create it though?

Edit: Got it! If anyone else is wondering, you select the nodes you want to convert to code, then you right click on the canvas (not a node) and there you can find the “Node to Code” command.

Brilliant stuff team! A BIG thanks to all involved.

Currently it seems that the support for local packages is limited to a network drive that everyone has write access to. If the only have read access it will not load the dyfs.

Hello John Pierson,

That’s correct, current functionality implemented considering a role of BIM Manager or a person who is responsible for managing all packages for the team. Team members cannot upload packages to that folder but they can access those packages by configuring that path.

However in general if you have not access to network drive you cannot copy paste content to it, so that’s the same behavior what you will find while publishing packages locally.

We love to hear more feedback on our latest release.

Keep using Dynamo!



I have some complex Dynamo files, and when I add some small pice of code (like code block with one variable to check some values), new Dynamo 0.8.2 is recalculating whole file, instead of some part only. Dynamo 0.7.5 didn’t have that problems - small change, small calc time.

Node2Code is COOL

Hello Rade Tomović,

Can you try switching to Manual Run mode and turn on option from Settings>Show Run Preview.

This will provide orange color to nodes which are going to execute.





I Download and install 8.2 Ver. But background 3d workspace dont show. Please Help Me



Thanks for all answer

Bbut my problem is in geometry view, When i swich from node view to geometry view dont show any thing at all.


I have the same issue as Morteza. Could you figure out what was the problem?

Nothing shows in my 3D preview navigation screen.

Hi Shani



I think it is a hardware problem.What is your PCs graphics card, I have quadro fx 2800. Also In watch 3d node dont show any thing. This problem have been found when The workspace was changed to new


I noticed that too on lower end laptops and in Parallels. It really takes a gaming spec desktop machine (in my experience) suitable for Revit projects.

On another note: why isn’t the 3D background preview always right side up… the orientation of the vertical axis seems to be random, and not always up/down. Sometimes the view is constrained to a side view which I can rotate to bring another side in view, but it’s useless or clumsy at best. I’ll try to install a newer build and report back.

One thing I’m wondering: Is there a way to package all custom nodes so when you send the dyf file to someone else, the can use it without downloading all the packages you have downloaded as well? I had a few situations where I scripted a basic sequence and sent them to others in office but they had to download all the packages. And Dynamo wouldn’t even tell me which package the node is from so i had to either guess or go back to my PC to find out.


Is there an option I am not aware of or are there any plans regarding this for the future? I’m assuming including a custom node wouldn’t cause an issue with file size or anything as they are already just a few kilobytes.

See this addres:

Download and install 10/1 daily build, this work well in my laptop.