0.8.0 release candidate


#1

Hi Everyone,

We are getting ready to post the next approved stable build. We’ll be letting it “bake” for a week, looking for any lingering regressions or big bugs in the new functionality. Feel free to try out this build, and please please please let us know if you see anything nasty (or lovely . . . we like the positive feedback too). You can see the list of major new functionality on the Readme page of github, or in the Readme at the end of install.

Because this is a jump from 0.7 to 0.8, you will be able to have any 0.7 era Dynamo installed side by side with 0.8, so no worries about having to move back and forth with your old builds. There is also a one time copy/paste of your 0.7 packages to the 0.8 package folder as well, so your first startup may take a little longer.

Thanks!

The Dynamo team


#2

Awesome, pretty exciting Zach! Unfortunately, the ‘this build’ link runs into a ‘Oops this page doesn’t exist’ broken link.


#3

Great update. Thanks.

One of the inconveniences for me is that when I search something from the library, Dynamo doesn’t show me every nodes which contains the word I input. For example, when I search ‘select’, I can see only 4 of them in this version. I wish I can see all of them. And it seems the search results be changed when additional packages are installed. I don’t think it’s a good behavior for users.

이미지 1


#4

oh, and please check the issue I’ve posted a few days a go.

http://dynamobim.com/forums/topic/direction-of-ellipsearc/

Thanks.


#5

I’m not sure if I’ve got local problems at my end (A few issues with pervious unstable releases - think my registry is corrupted), but the ‘Sandbox’ version didn’t work when I tried to open it up. Not sure if anyone else has this problem?


#6

Thanks Zac. One thing that jumped at me when trying one of the 0.8 builds is the run state that is now saved per project. I had a workspace crash on me and because it did so when I had it set to run automatically, it kept crashing and hanging up. In 0.7 builds, I could disable and set to manual, then open the workspace and make necessary corrections before running again. If saving this setting per workspace, we need the ability to open in “safe mode” so to speak, so we can troubleshoot and fix what’s wrong. Thanks.


#7

I have to agree with Dave. I am not super fond of the following.

2015-03-30_15h41_26

 

 

Currently the way we are using Dynamo graphs in our office, is saving them on the network and people can run them. We also post instructions in the graph as somewhat of a “starting view”. I think if the graph runs right away with no warning, this could be problematic. I realize that the option is there to save it as manual run, but there is the off chance someone would save a graphs as run automatically.

 


#8

erm… just started using v8. Am I the only one who finds the search function so slow as to be almost unusable?

Seems to be the loading of the icons that takes forever the first time and then works faster the nexts time. It is only possible to type one letter before you have to wait…then type the next letter and wait…

Either loading all the images on startup with a longer load time (If thats what it is) or the option to turn them off completely (Classic mode?) would be preferable. Or at least type the whole word and press enter before searching/loading.

Also +1 for having Manual as the default run option

Apart from that its looking great. Thanks!


#9

Joseph,

we have seen a couple of reports of this slow search issue in windows 8 machines, but have been unable to reproduce it in the Dynamo team’s environment. Can you add any information about your machine to this github issue?

In particular: Running Dynamo inside of Revit or in Standalone or both, version of windows, other Revit addins

Thanks

Z


#10

Has anyone else seen issues with 0.7.5 after installing 0.8.0? I had to do a full uninstall of both yesterday after it kept wiping out Ryhnamo.


#11

The release has been stable so far. However, I am experiencing slow searches. Running windows 7 and Dynamo within Revit. Only Ideate Bimlink & explorer and sefaira installed as plug-ins


#12

Also running it in Win7 in Revit. Its a test machine so it has a whole bunch of different addins. I will try it on another and see if it is the same.

(Just tried stand alone and it wont run, so maybe just needs un/re-installing).


#13

So I just did a test;

I removed/uninstalled everything dynamo related and installed the latest version. Then I opened a simple revit project and started dynamo, same machine same add-ins etc. Search function was responsive and worked fine. Then I opened a large workshared project from a network location, it seemed slower but was still usable.

Then I opened a definition with custom packages and noticed they where missing, so I restored all the packages I had before (Just copied them to the folder under user\roaming\appdata). Search was very slow again.

So this seems to be made worse by searching the custom nodes.

Finally, I opened the same workshared project, discarded the worksets and saved it locally, because I know the location where I am working has a slow connection to head office where the central file is (I often get warnings from WSM that the connection is slow and revit stutters a bit). Search was fully responsive again.

Bizzarely the delay in searching appears to be somehow related to the general slowdown of revit with a poor worksharing connection, although I never noticed this before with version 0.7.


#14

Capture.2PNG

 

 

 

 

 

 

 

 

“Point.ByCenterPointRadius” node not working after Rhynamo package installation(i didn’t try for other packages)

Working for one point but if the entering node is a list, it’s fails.

 

 


#15

This is a post I shared on my companies intranet regarding my install problem. Not sure what caused this, it could have been many things.

 

So 0.8 is now the stable build, meaning that downloads from dynamobim.com/ will default to 0.8.

I have been using “unstable” daily builds, this allows me to stay current but at the risk of bugs and open items that could impend my workflow.

When I went from 0.7.6 to 0.8.0, things broke. The new 0.8.0 was installed but without an .addin file (the file needed to have a dynamo button in Revit.) Also I had to manually uninstall 0.7.6. because it was still showing in my start-up bar and as a duplicate desktop icon.

I think all of this is because I’ve been playing with the daily builds and “breaking stuff.”

BUT if this does happen to you there is a nifty fix. After uninstall all outdated dynamo files. Within the new dynamo folder structure is an .Addin Generator, close Revit and run that. “C:\Program Files\Dynamo 0.8\DynamoAddinGenerator.exe”

This restores the connection to Revit by adding the proper connecting scripts.


#16

Joseph, mine is slow in searching on windows 8.1 with no workshared projects running, even with no packages. And that is the case with 0.7.5 as well. The Dyanmo Wizards at Hogwarts are analyzing :slight_smile:


#17

Hi folks - the stable 0.8.0 build is now available here:

http://dynamobuilds.com/

Thank you for your help testing this! Please continue to post your feedback as you use it in your daily work.


#18

Maybe I am missing something, but when I install 0.8 and double-click absolutely nothing happens. It does not fire up, no GUI, nothing. Any hints on what could be wrong? 0.7.xx works just fine.


#19

Why did you change the “one step forward”-Function, if you have pressed on the slider?

For me it was very useful, to analyse the Listelements. Now I have be careful, what number the slider is set :frowning:


#20

On my laptop, Dynamo 0.8.0 launches in Revit, but not as a standalone.

Is there a solution to this?

I’m on Windows 7 Enterprise (SP 1) and Revit 2014. I don’t have admin rights.