Custom package made with pkg.json not visible in add-ons

I’m trying to create a custom package to store my .dyf files neatly in a separate row in Add-ons. (maybe in preparation for some C# learning in Visual Studio)

I tried with this tutorial - and when I compile the package with the first “Hello World” node, it does produce pkg.json + bin folder in desired location, but it won’t appear in Add-ons and in a dropdown menu when creating custom node.
EDIT: It does show up in Packages Manager but that’s it.

Tried both meddling with pkg.json inputs as well as creating _DynamoCustomization.xml file - still not showing up.
Any help? Thanks!

bumping for I still haven’t found the solution

Here’s code in my pkg.json

I don’t know what is causing your particular library issue without trying to build your code and import it - unfortunately, I don’t have the bandwidth for that - but you can try the official samples - they may give you better luck:

Is it possible to take an even easier approach? I just added new destination in Settings ->Manage Node and Package Paths and just stuck my .dyf’s there. Restarted Dynamo and they won’t show up… Is there an easy way to just load my premade .dyf files into workspaces?

Have you tried creating a package from the DYFs?

if all you want to do is load some .dyf files - just put them in %appData%/Dynamo/blah blah blah / definitions/

1 Like

that’s where I have them, and they won’t show up anywhere…

as i’ve mentioned the package from pkg.json is recognized in Package Manager, and show it’s contents but the content won’t show up in the side menu

please look at the path I suggested again - it does not include the packages directory - but the definitions directory.

1 Like

Sorry, corrected it, put it in definitions folder, restarted Dynamo and…
where are they supposed to display?

edit/disclaimer - JEMSnodes visible is an effect of me just creating Custom Node and manually adding it to this path, but I’d like to add these .dyf files manually

I would do that, but Autodesk licenses in my firm are distributed from a server - therefore i’m not logged in in Revit to any Autodesk account that has access to Revit…

@solamour good feedback on a blocker for the package authoring here.

Could you author the package at work? Or check out a license for the evening?

okay - so you want each custom node to appear as a separate entry in the node library? Not nested under a category? I don’t think you can do this with a package - even with a customization. I’m not 100%.

With your custom nodes in the definitions folder, I think you can get this behavior, but the names are important - if you use a . the first section will be turned into the outer category. You’ll have to give each custom node a different category name to get it to show up in individual rows. Why do you want this?

I’m working on a remote desktop, so there’s no difference. But I guess I can fix it with our IT admin.

No, I would just like to have an option to put my .dyf nodes in some directory on my drive for Dynamo to read them as I organise them.
I want just as other publicly available packages have subcategories like: package.Revit package.Dimensions and so on I’d like to have this kind of functionality with a locally published package - but without logging into Autodesk account and publishing it with the OOTB method.

and the method of putting them into /definitions did not work - they didn’t appear anywhere :frowning:

And so far doing it the “raw” way compiling some basic code with Visual Studio did not work for me apart from showing the package in Package Manager

okay -
the nodes will end up in different places depending on their names and their categories. You can try uploading a sample custom node and I can check where it loads on my system if you want.

If you want to create a package but you can’t publish locally because of license issues then your idea is not a bad one - to use the sample to generate a dummy package and then fill it in with .dyf files.

Please try with the DynamoSamples project, it will generate a package in the repo that you can add a custom package path to (point the package path to the directory containing the package, not the package itself) OR copy it to your package folder.

Atleast this way we can figure out if custom package loading is somehow broken on your system or something else is going on.

also - whats in the JEMSnodes category? Is it empty? Or does it contain the custom nodes you placed in definitions?

it contains custom nodes I placed in definitions

will try with the other github repository you posted and get back with the outcome, thanks for helping out

you said

and the method of putting them into /definitions did not work - they didn’t appear anywhere :frowning:

and then:

it contains custom nodes I placed in definitions

  1. so I need to clarify, maybe I am misunderstanding - so placing custom nodes in definitions worked or it doesn’t work?

  2. I’m pretty sure we’re both on the same page that your package is not showing custom nodes added to the dyf folder?

  1. Only custom nodes i’ve made in the .dyn workspace were saved and are visible in the sidebar and are available to be loaded into other workspaces. When I make a custom node without going through “Create Custom Node” window, from normal .dyn workspace, but just saving a different .dyf file and then manually putting it into a directory which is supposed to read custom nodes from - it just won’t show up.

so the custom nodes that appear in my sidebar are the ones i’ve made through create custom node, and the add-ons categories visible appeared only because i’ve manually entered them in this window when creating them in the workspace. They did not appear there after compiling the git-hub sample package

  1. Yes, i’ve made a custom package using method of compiling basic pkg.json file and a basic HelloWorld.dyn file and exporting it into %appdata%/Roaming and so forth directory. It does appear in my Package Manager, but then when I put any .dyf file info it’s /dyf directory - it wont show up