Locally published custom node package - but can't see on the side

hello everyone,
I made bunch of custom nodes into a package and published it locally
However I neither see it on the side of my Dynamo nor automatically loads up - just like any other packages that you see below. My package is located at the same spot as other packages.

Can somebody tell me why this is happening?

My locally published package is called ProjectHealthCheck (highlighted in yellow)


"Settings > Manage Node and Package Path " Follow his path.

@mixology It’s because all of your Custom nodes are pointing to Bakery and Clockwork.
So the nodes do show up but just not under your package name.

oh wow how were you able to figure that out…? haha
so should I go into individual custom nodes and change the direction?

but the bigger problem is - sure they may have been loaded in different packages like bakery or clockwork but the nodes always throw a red error saying these custom nodes have not been loaded.

why wouldn’t they be automatically loaded when i checked the setting->manage node and package path and everything?

@mixology Yes, changing that should make it work.

Not sure why that’s happening!

Thank you very much @AmolShah

Is there a way to create a new Add-Ons Category? it seems like there are only premade add-on categories that I don’t want to point to.

I pressed + symbol next to add-ons. I made a new folder and try to create a new add on by adding that folder but no good.

could you please help me quickly if you get a chance? thank you!

@mixology Just type in the name of new category you want for the 1st node and it will start appearing in the dropdown for the other nodes you make after that.

Note: I haven’t worked with packages since a while but I recall doing something like that in the past. So give it a try.