Curves From Cad layers

Hi,

I’m trying to convert lines from DWG to curves in Revit.

This node is from BIMORPH.

Should work… is equal all examples in website, i think that isn’t working because i’m using Revit 2018.

Anyway… is anybody knows how to convert a line to a curve?

i need a curve to create walls…

I think you need to feed layer names and model curves, I’m using the package and so far no problem at all.

I think you may need to install the new version of Bimorph to use it in 2018

“BimorphNodes v2.1 is now 2018.1 compatible, every node has been upgraded, and the entire package has been ported to C# to support the future development roadmap.”

I’m using v2.1.2

Hi @daniel.petrin

Use “Curve.Approximatewith Arc and LineSegments” node.

i did this… but not!

dwg parede2.dwg (37.9 KB)
TESTE1.rvt (1.5 MB)
criar parede 2.dyn (5.8 KB)

i line from autocad(dwg) to a curve in revit

this node curve.appro… should work only to revit

It works fine:

1 Like

@daniel.petrin It works for me also:

You can use OOTB nodes also:

The choice is yours :slight_smile:

3 Likes

no way kkkk…

you just got my files and run dyn?

i tried today again, with new files!

image

image

image

teste convert dwg.rvt (1.5 MB)
convert.dyn (1.7 KB)
teste1.dwg (33.8 KB)

@daniel.petrin Did you tried with the OOTB nodes which i showed above?

1 Like

Have you been testing this with the intention of creating walls from and AutoCAD dwg.

If so how are you trying to overcome issues such as wall thickness and selecting only one of the parallel lines defining the wall?

I was hoping to create something to generate walls from dwgs such as this.

wall dwg snapdwg example.dwg (947.7 KB)

Hi @JAC

Could you please start a new thread we can’t have 2 solutions in one topic. Thanks!

1 Like

Yes… i got some problems, because, in the dwg file, i had CURVES AND LINES… i dont know why…

and i was using in my dynamo only LINES… and after i should convert to CURVES…

BUT, i got a way to convert CURVES in LINES…

Yes… is exactly what i’m doing… creating walls from dwg…

i got it… just doing a final teste…

The “problem” is the one defined in the title which is optionally refined with the tags, that’s how we find what we need through the search field (or not).

1 Like

I’ve got the same error in Cad.curves node.
Everything works fine after update to dynamo 1.3.2

I don’t know if you solved then… which version of Autocad files you were feeding?
I noticed that Revit 2018 has problem from CAD from 2013 above, so I always saved as 2009/2013… Maybe it can’t read any instances because it cannot access to the file…

Hope it helps you and other people with the same issues!

Would you mind sharing the script?