CurvesFromCADLayers using bimorph not working

hello, I am trying to read curves from CAD files using CAD.CurvesFromCADLayers in bimorphNodes package, but it doesn’t seem to be working at all after ver 2.0.0, though In the ver1.5.1 it worked.
is there anything wrong?

@Xin_Cheng Can you post the DWG? The algorithm hasn’t changed that much between the versions, other than being ported into to C#. There’s been a noticeable optimisation in version 2.0.2 which has changed the conversion of Model Lines, but I see you’re not converting to Model Lines so it cant be that.

thank you for your reply.
here is the DWG files.
pipeCurveTest.dwg (55.6 KB)

and i tried to use Converting Model Lines, it fails.

it worked. after i change the true for createModelLines and set the lineStyleMap.
So, after 2.0.2 both createModelLines and lineStyleMap are necessary?

Nope, it should work the same as before. Both of those inputs are optional.

I’ve tested my end, and everything works as expected, whether converting to Dynamo curves or Revit Model curves so I dont know why its not working with you. Can you show me the error you get. Also it might be worth checking your units. Thats the first thing I can think of that may cause unpredictable results:

it all worked fine in my Revit English version.
Maybe it is about Revit language verion or Dynamo language version?
In my CN version, it just worked with all four parameters settled.