Corrupted file, backups won't open either... recently moved to 2.0

Hi, this is a bit strange. One of my scripts is coming up as corrupted. I’ve recently installed Dynamo 2.0. Tried opening it with 1.3, still fails. My backups do this also. Other scripts open okay.

The file seems intact in notepad.

I’ve posted it in case anyone can help, thanks.

ME Appliance Connection Wizard.dyn (27.6 KB)

so, Dynamo does not even open the DYN then? any error messages? can you open the DYN in a blank project? which version of revit?

this file has been converted to json so it will only open with 2.0 - does it not open there?

HI guys, thanks for the help.
Revit 2019.
Other dyn files open ok. This is the only one that is broken to my knowledge.
I tried to reproduce this to relay the exact error message (corrupted file) but now Revit and Dynamo crashes as soon as I try to open this file.

further info. Crashes Revit with a fresh blank project. Using Dynamo 2.0

I see there are a couple custom nodes which this graph uses, are those nodes available in dynamo?
Do they work in other graphs?

Hi @MuirEng

Try opening this file ME Appliance Connection Wizard (ForMuir).dyn (28.5 KB)

Okay, thank you for the help. I managed to recover the file after a few reboots.
Michael, all the notes are from published packages.
My system seems to be working normally now, except dynamo does not recognize keyboard shortcuts. (control C/V are the most annoying to live without)

1 Like

okay, it’s a known issue

1 Like