Copying Views and details

Hi…

Is there any way of copying views (Model views not drafting n all) from one project to another by using dynamo?
I need to copy views from one project to another…

Thanks in advance.

yes that’s possible, here’s one way

4 Likes

Do I need to link the file from which I am copying to my working file?
Or just need to run the script?

yup you need to link

Ok…thanks for your time…I’ll give it a try…:grinning:

Thank you Lucifer…It really helped…
Modified it a little as per the need…

Thanks again…:grinning:

One more thing can we copy sheets from the linked file…?

Thanks for this! I am trying to do the same exact thing, but I am running into an issue where it copies some views and not others. I noticed it says null under CopyFromLinkInstance node. Am I missing something?

I am currently testing this in a blank project. Thank you for any feedback!

Hi Kajmera,

When u add a new view to copy, how are you refreshing the script to check if there is change in the linked model?

If you are just reconnecting the LinkInstance i guess you get this. If you close the script and open again it should run fine.

Regards

works fine fom me, try @maltheshkathare’s advice

1 Like

if im not mistaken, NO.

Hi,

Yes, I’ve been closing the script and reopening whenever I add a view to copy, but still getting the same result.

Is it possible that the views depend on something? I tried copy/pasting all the model elements in the new model in case the views weren’t pasting because of missing elements in those views, but it’s still giving the same issue. Any other ideas?

Thank you both for your help!

I am having the same null issue

Try updating the spring nodes package, that might be solve the issue.

Since these packages are being updated frequently there may be chance there was a bug and it is solved in recent releases.

It works for me in 132.2.8 version
image

Hi…are u trying to copy multiple view at a time?

I see. Thanks for the info. I’ll double check my version and report back whether that resolves the issue.

Hello, Yes I was testing with 3-5 views to start off and it only copied one of them. Then I tried with many more views and nothing copied unfortunately.

Hi…use this…!

You can add many more view in the “Get the views to be copied part”…

Please mark it as solution if it solves your problem…

Thanks…!

1 Like

I’ve just tried the method outlined above and have encountered the same null problem.

I’ve filtered my links so that the graph looks to copy from the latest link only.

When I run it, I get a null under the CopyFromLinkInstance node like @kajmera.

Unlike @kajmera I have not had any views copy successfully yet.

I can get the null to go away if I change the string name being searched for.

Unfortunately not all the views are showing as copied in the graph results (similar to kajmera) and unlike kajmera, none of the views are copied in actuality.

Very odd.