Can't filter objects and set parameter value

Hey

I am trying to filter all curtain panel families that have the ‘beläggning’ parameter and set its value to a simple text. But it doesn’t work. First I tried to ‘Select Model Elements’ but the ‘select’ button didn’t work even if I selected geometry in Revit.
Now I selected all category and at least it draws data from Revit, but not able to continue…

Any advice?

hi @Kaloyan_Tomov1
What exactly do you mean by " families that have the ‘beläggning’ parameter " ?
So far you are querying the ‘beläggning’ parameter value for all your curtain panel. The absence of error means that all your curtain panels have that parameter.

Assuming your ‘beläggning’ parameter is of type text and not YES/NO, it seems like you are missing to connect the result from the node “Element.GetParameterByname” to the “a” input on your code block. With no input, the code block will return false in any case.

Yes but I need to set a value to all these parameters. That si my end goal. And what i struggle with

Thanks

I tried, but still doenst change anyhthing…

Could you please share a sample file with the curtain panels and your dynamo definition? It is difficult to help based on assumptions.

try this:

mmm that not exactly what was suggested :smile:

1 Like

Sorry I’ve sent an old screenshot

is it a type parameter you are trying to set?

in that case you need to get the family name instead and then add the parameter to the type instead.

it’s actually a project parameter,

thats no go… you need to have it as a type or instance parameter for Curtain Walls!
otherwise is your method completely wrong!

A projec parameter assined to curtain wall panels? Is it a type or instance parameter?

its applied on curtain panel category and wall category. Assigned on type level

then you need the method i described in

here is a solution using Element.ElementType (which is family types)

So if the parameter is set like this:

Then this should work :

can’t find the FamilyInstance.Type component? is this an old version?

I’m using dynamo 1.3

nop… both Element.ElementType and FamilyInstance.Type have been present for a long time… try to type the name fully

1 Like