Cannot install as Installer is finding 'newer versions'. I have uninstalled and cleaned every way I can - help!

Hi

Our practice has live projects in Revit 2016 and 2017. I have Dynamo scripts I run in v1.3.2 (latest release compatible with 2016).

I recently re-installed Revit 2019. That seems to have installed Dynamo 1.3.3 and 2.0.1.

I had this issue a while back and I was able to uninstall 1.3.3 to roll back to 1.3.2. At that time, I found the Autodesk Uninstall Tool didn’t fully remove it and nor did the standard ‘Uninstall Application’ in the Windows System Settings. After a little digging online I found a Windows tool called ‘Microsoft Program Install and Uninstall Troubleshooter’. That did the trick.

I’ve tried the same steps again but it’s not working this time.

After using the 3 tools (Autodesk tool, Windows tool, Windows Troubleshooter), I then removed left-behind Folders from \AppData\Roaming and from \ProgramData. None of the 3 tools is recognising that there is any Dynamo content left on the computer … but I’m still getting the message that I can’t install a component because there are ‘newer versions’.

Install%20Error

Can anyone please help?!?

(Windows 10 Pro, btw)

The Microsoft Install and Uninstall Troubleshooter tool has another option if the offending program doesn’t appear on the list … to remove it by Product Code.

Can anyone advise what the Product Codes are for Dynamo 1.3.3 and for dynamo 2.0.1?

Uninstall%20by%20Product%20Code

As a last resort you could try

cmd
regedit
and find “Dynamo”
delete all keys

Reboot after

It might kill your computer so be carefull

This is related to revit 2019 and i would suggest you read the following post i have posted as a work around.

Here’s what I did just recently when I needed support for 2016-2018.

  • Install Dynamo 1.3.2. Make sure to isntall Dynamo Core, and all Revit versions.
  • Go to Programs and Features and Uninstall DynamoRevit only. DO NOT remove the DynamoCore.
  • Install Dynamo 1.3.1 which will complain that Dynamo Core will not be installed since a newer version is found. That’s fine. Just let it install DynamoRevit 2016-2018.

Now you should have the DynamoCore 1.3.2 and DynamoRevit 2016-2018.

Cheers!

1 Like

Hi Konrad (and Brendan).

The problem is I am not able to install 1.3.2 at all.

None of the 4 Revit installations (2016-2019) Revit show that there is any Dynamo - it’s just not there under the Add-Ins (or Manage) menus. Even so, the 1.3.2 Installer tells me I have ‘newer versions’ than 1.3.2.

On the basis of Brendan’s comment, I have uninstalled 2019 for the time being. That hasn’t helped.

I think I’m going to have to tackle the Registry … which is past my experience level to be honest.

Could it be the 3-version limitation?

I thought it might be related to that, hence uninstalling 2019.

That didn’t work so I’m currently deleting Dynamo Keys from the Registry.

Sweaty palms here.

Ok so I have partially recovered the situation via a Registry edit:

I have 1.3.2 in 2016, 2017 & 2018.
I have 2.0.1 in 2017 & 2018.

I am without Revit 2019 as I can’t afford to not have access to 1.3.2 in 2016.

This is pretty frustrating but I don’t need 2019 at the present time. If I have to go down that route, I’ll look at Brendan and/or Konrad’s guidance on the dual installation.

Thanks everyone for the input.

It is defiantly related to the install of revit 2019, i think i did the following process.

Uninstall revit 2019 then uninstall dynamo 1.3.3(core and revit). If dynamo 1.3.3 isnt installed prior to installing revit 2019 then I reinstall it first then uninstall it.

Then i was able to install dynamo 1.3.2 onto the system.

Then i reinstalled revit 2019 with the dynamo 2.0 msi files written into its installer. then everything worked :slight_smile:

Hi Brendan

I’m pretty sure installing 2019 was what wrote Dynamo 1.3.3 over my existing 1.3.2 setup.

I should have paid more attention perhaps but I don’t think it gave me the option to not do it.

I can’t quite follow what you’re talking about re ‘editing’ the installation - I take it you are installing from a downloaded package rather than using the ‘Install Now’ from the accounts page?

Download it and it should extract all the files into a install folder as similar to this

Then you can see a folder called x64 then within this folder is a dyn folder, this is where the dynamo install files live. You need to get the msi versions of 2.0.1 and put them within here. This will make revit automatically install version 2.0.1 instead of 1.3.3.

Other option would be to go into the setup.ini file and omit the dynamo install part(not tried this and cannot say it will work).

1 Like