Bakery installation problems

I’ve always had problems installing Bakery, sometimes having to reinstall all the packages to get it working again. The point is that Dynamo routines in the company should be used by everyone, although most people do not know how to deal with Dynamo. So the users have constantly encountered problems in the routines that are caused by the bad installation of this package :expressionless:.

My question is: is there an easy and 100% reliable method so that it can be installed without further problems?
At least something that I can put in a small manual to have a reliable solution (preferably that solves the problem on the whole server, and not from computer to computer).

I found several topics on the subject (the most usefull ones above):

But none of them seems to present a really definitive solution, specially when Dynamo have to be used in many computers, and by people who do not really know how to manage the software.

1 Like

Hi @luupieper

You can download the package from and unzip the package in your packages folder to avoid any problems.

Hope that helps!

1 Like

@Kulkul’s answer is the best one regarding bakery.

However, I want to add that you should check which noted you actually need from bakery. If you aren’t finding yourself using those nodes, maybe the effort for deploying it, simply, isn’t worth it.


Thanks for the replies!

In fact, I tried it this way @Kulkul but even after that, it keeps giving me problems.

@john_pierson I agree, and to be honest, I replaced all nodes from the Bakery on all routines used by the other elements of the team (who do not master Dynamo).

But I decided to ask in the forum anyway… because in case of a good solution for this problem I would like to continue using this package. Otherwise, I’ll prefer to avoid its use.

Hello @luupieper - We are actively doing work right now (Not going to hit Dynamo 2.13, but ideally the release after) that should help alleviate this :slight_smile:

1 Like

Sounds interesting. I’ve typically guided people away from packages that draw on dependencies, which includes Bakery. It looks to be unmaintained these days, but I might be mistaken. Usually another sign of a package that comes with risks in being used.

1 Like

One issue with Bakery in specific is, it comes with an .exe file in the “other” folder that you have to run after installation. I don’t know that Dynamo can (or should) auto extract items like that for users via the package manager.


Hi @john_pierson - Won’t be auto extracting things, but rather providing control to the user to choose when and how Dynamo loads things :slight_smile:

1 Like

Hello all,

I’ve been banging my head around this issue for couple of days already. I’ve tried everything, still it is not working.
I’m using Revit 2021 and Dynamo 2.6.

The thing is, even though I’ve uninstalled Clockwork already and now trying to install the Bakery package, it automatically installs all it dependencies and while installing itself, give the error.
I’ve also tried installing the same manually, but to no avail.

I’m in desperate need of Revit section by lines node, but am unable to proceed ahead.

It would be great if someone can just guide me (or rather us) with a fool-proof method.


@luupieper @Kulkul @john_pierson @solamour @GavinCrump

Think Datashapes had a node viewsection by line


Thanks for responding @sovitek

Anyway, just null.

1 Like

Strange works fine here, the issue here is you dont feed in a viewfamily type.

1 Like

Oh yes, My bad!
Just installed Rhythm package.

I feel embarrassed to ask these questions but in the ViewFamilyTypes node, I’m not able to find “Section view”, or the Snit, which you used.

1 Like

Hi @atharva.purohit466SX …can you make a section manuelly ? try this and see which viewfamily type you use…hope it helps


Snit will be in a different language I’m guessing. This is the default section when not using a template for reference.


We just call it snit in danish…you can name them as you want