Bakery Package doesn't work

Hi there,

I’ve downloaded the Bakery package and I put it in the package folder, but Dynamo doesn’t recognise the folder.

I opened one of the scripts of the package an then all the package appeared in the Dynamo’s tree but no one works at all. It is allways the same error:

Hi Manel,

Try uninstalling all custom packages, restart your PC and install only Bakery package first.

Please note that before you uninstall all custom packages you keep a record of all the custom packages.

Good Luck!

Hi Kulkul,

Because of my company firewall, I can’t install directly the package from Dynamo, so I’ve download them and copied in the package folder. I deleted everything, uninstall and install Dynamo and just put the Bakery package and still doen’t work.


Hi Manel, I am the creator of Bakery. I haven’t had the crash problems you experience. I am using Dynamo 0.9.2, usually on Revit 2015. Bakery has a lot of dependency packages, as shown below. As a workaround, you can download my entire packages folder here for testing purposes.




Thks Luke,

I’ve downloaded your packages and put them into the package folder.

Sth strange happen in my Dynamo. e.g: If I copy your BlackBox folder, Eleemnt is hidden, element from & to IDs and Element in View to my flder, the rest of the packages don’t appear in the library of my Dynamo. If I delete them, the rest appear.


I don’t know what happen :frowning:



Interesting… I will try and remove those dependencies for next package upload.

Ok thks.

@Luke_Johnson hopefully you’d be able to help (or anyone else if you know) - I have tried to install Bakery without success. It was working fine before but I don’t know what’s the problem now. I have uninstalled all other packages and have restarted my PC several times before and after installing Bakery alone. It still won’t work…
When I install it, all I see is this:

You have to run the “Bakery.exe” in : AppData\Roaming\Dynamo\Dynamo Revit\1.3\packages\Bakery\extra
to unpack the nodes.


Thank you @Alban_de_Chasteigner, I did that but I open and restart Dynamo again and still shows the same way (sorry I should have mentioned that I did that too)

If the file “Bakery.exe” is broken, you can try to download the package with the package manager inside dynamo or on

It still didn’t work with the latest version… It worked when I downloaded the previous version though.

Thanks for your help!

Unfortunately the Package Manager doesn’t allow me to upload Bakery recently. You can download the nodes from and put them in the packages/Bakery/dyf folder. This should work.

do this step by step

extract .exe file

create folder tree by this order inside folder bakery