Automating Automation - Journal file could not be run to completion

I am working on using Andreas Dieckmann’s method for automating dynamo graphs on multiple Revit projects. I have the master graph working without any problems and it opens Revit for each of the models in the directory that it is pointing to. I get an error in Revit stating that the journal file cannot be run to completion. The dialogue box needs to be closed as well as Revit before it moves onto the next file. The slave graph that is intended to be run does not run. However, the journal files are created. Has anyone else tried to use this technique and encountered the same issue?

Have you made sure that your setup meets the requirements?

Have you made sure your setup does not fall within the conditions described in the known bugs section?

This is the exact issue I am having @davidfink6724. If I figure it out, I will share it. How are you creating the journal files? Mine are text files.

Maybe its our format of the journal files and the batch file.

I doubt that it’s an encoding issue.
@davidfink6724 @kiknchikn2060 Could you please create an issue on GitHub with a detailed description (and possibly sreenshots, graphs etc.):


Andreas, I have both Dynamo Studio and the plug in installed. Could this be an issue? They are both the same version 1.2.0. Otherwise, I seem to meet all of the requirements.

@kiknchikn2060, my journal files are text files as well, but that is the format the graph creates.

I’ll do that asap but I doubt it’s the script. I’ve seen your videos of the script in action. I strongly feel it’s how I’ve formatted the config file. But I could be wrong.

I am one step closer but it is still not working 100%. Unfortunately, I can’t see why it started to work. The graph runs and opens Revit and closes between files but I get a different error “Failed to open document” The problem is either in the process path by arguments or the Journal files clean-up nodes they are both returning 0’s and nulls respectively. I am still working on it so I’ll let you know if I find a solution to this problem.

Now I am really close. After correcting some small syntax errors the graph works for the most part without errors. It opens Revit and the project and closes Revit. It just does not run the Slave graph or save the Revit project.

Glad it’s working. I’m still getting the journal file error even with the white spaces removed.

It is still not working 100%. The graph opens the Revit project, but it doesn’t save the project, so I am a little uncertain if it is running the slave graph. I thought it may have something to do with running the graph for a 2015 project but I am getting the same results with 2016.

I still can figure out why the slave graph will not run or the why the Revit project does not save. Here is my graph is there something that I am missing?

Master automation.dyn (16.9 KB)

I have an issue when running revit files that are central . Notification is about script being unstable and prompting to enter interactive mode. Issue does not occur if i first detach all the files from central.
I am looking at the way to automate the process of opening revit files by the master automation in “local copy” mode, but cannot find script to do that. Through revit api forums, it transpires that revit does not have command line switches ( at least, documented ones), that would allow to save local copy.
Andy, do you think you have a solution to open central files or " localizing" them While opening by the script?

To reply for earlier posts, the only other fixes to automation to work, as I found - keep syntaxis without spaces for all folders and file names.

I am thinking if the code implemented in the solution here:

Can be python- scripted to take batch of central files and to convert them to local files

Hi davidfink6724, it seems you want to change some parameters in your Revit projects, I have the same problem as yours. I cannot save Revit projects. Have you figured it out now?

@davidfink6724 did you ever get to the bottom of this? Im having similiar issues

1 Like

@JB86 @davidfink6724

Probably a bit late to the party on this but I’ve recently made public a similar project that can batch process many Revit project and family files with your own custom Python scripts. There is actually preliminary support for executing Dynamo scripts from the Python scripts too.

For workshared central files there is the option to create a new local file or detach from Central depending on your needs.

It optionally can choose the appropriate version of Revit to use depending on the file’s Revit version.

I haven’t fleshed out a manual yet but the Readme should give you an idea of where to start. Feedback would be most welcome!


I have once again the same problem.

Journal file could not be run to completion
And the graph is not executed.

I’ve tried with my own script and with Scenario_A1_2017 (changing my version to 2018)
I’m pretty sure that I meet the requierements.

Anyone knows where does that error come from? What can I try to solve it?