Archi-Lab and Dynamo 2.0.1

Hi all, Hi @Konrad_K_Sobon,
as mentionned in another post I tried hard to get Archi-Lab going with 2018.3 revit and dynamo 2.0.1.
I tried to re-install everything, flushed the temp, all dynamo related data, no chance.

as soon as i remove it from the package folder, I get no crash.

in the log file i get these lines just before it does crash

2018-06-27 06:20:13Z : System.InvalidOperationException:
2018-06-27 06:20:13Z : There already exists an AlsoKnownAs mapping for Fill Pattern Targets.

I did try again, and again this morning;
the logs told me it succesfully uninstalled after restarting after the last crash. So I guess, it was flagged for uninstallation (for a long time) and did not manage to uninstall it before.

I then got it from the package manager and all was well, for the time being

I hope that helps others at least

Yes, so even when you uninstall Dynamo, it’s not going to remove any of the packages. After a fresh install the packages that were previously downloaded and now live in %appdata% location will basically get loaded in again. You have to either remove the packages manually, or use the Package Manager to schedule their removal and close/open Revit.

So should work just fine with Dynamo 2.0. There is a version of the package that was updated to Dynamo 2.0. I think it’s 2018.2.1 or something like that. It’s probably not the latest one.

1 Like

it’s not going to remove any of the packages.

I knew about it but I did not know the uninstalling process of packages was that buggy. I uninstalled from the package manager. It flagged but did not process up to a certain point when it decided to finally uninstall it (even though I already removed the files from %appdata%/Dynamo/Packages). Only after the flag was out of the way, I could install Archi-Lab without crashing.

Thanks for the Archi-Lab packages @Konrad_K_Sobon and for the reply

This seems like a bug with the flag for removal functionality of packages - can you please post steps to repro it if possible on github.

Also that version of archi-lab was not compatible with Dynamo 2.0. Please install the latest 2019.2.6.

1 Like

I’m also having an issue with Revit 2018.3 crashing every time I try to install archi-lab 2019.2.6. I opened Dynamo Revit\2.0 and the package folder and removed the folder and reinstalled 2019.2.6, but Revit crashed again. Is there something else I need to remove to ensure a clean reinstall of the package?

Maybe this will make sense to someone else, but I tried opening a blank Revit file and then loading and it worked!

(and I join Jean-Marc in thanking Konrad for making this invaluable package available to all for our use!)

After thinking it was fixed, I closed and reopened Revit to find the was not showing. What would cause a package to install and work and then not register as being loaded? Is it conflicting with another package?

So the way that versioning works for is that for a version 2019.2.6:

  • 2019 - version of Revit that it was tested against
  • 2 - version of Dynamo supported so Dynamo 2.0
  • 6 - build version that gets iterated every time I release an update.

Now, I just opened it on Revit 2018.3 and that specific version works fine:


At this point I can’t really tell you why its not working for you. It should.

Actually if anything @Michael_Kirschner2 says that this might be an issue with the viewExtensions:

I will let Mike tell me when its fixed and if there is anything that I need to do.

1 Like

I think the problem is at the Archilab Package. I have posted a thread on Andreas’ GitHub.
The Clockwork 2.x crashes in my latest Dynamo and Revit versions.

When I uninstall the Clockwork pakage the problem is over.

I don’t follow. You said that when you uninstall Clockwork, the problem goes away. How does that make you think that the problem is with the package? Wouldn’t “uninstall clockwork” = “issue resolved” mean that the issue was with Clockwork?

I am actually pretty sure that the issue is with DYNAMO. @Michael_Kirschner2 mentioned that there is a bug in Dynamo that is causing this. Clockwork AND are both really big packages, and Dynamo is timing out when installing/loading them. I am going to guess that deleting one or the other would solve the issue. Why? It would simply remove the time it takes to process that package, and viola, Dynamo works again. Did I miss something?

we believe this issue should be resolved by this pr:

in testing now.

1 Like

I found the issue: My own package link has old nodes from Clockwork in them. That bugs!

Hi…if i download the packages let say i download packages for 2019.2.2…can i rename that folder?
because when i click the 2019.2.2 it appears the name that unusually name…? so can i rename that form the original name?