Revit crashes when loading a script with archi-lab and Clockwork nodes

I’ve noticed that since installing Dynamo 2.0.1, I can’t have Clockwork 2.1 and archi-lab 2019.2.6 installed at the same time. If I do, and try open a script containing nodes from both packages, Revit and Dynamo crash.

When I have archi-lab installed, I get a notification on startup. Doesn’t pop up by itself, but can be seen when I click on the “!” in the upper bar. I pasted it into a text file, but I’m too new on the forum to upload the file, so here’s the first part of it:

While loading assembly archilab, Version=2018.0.0.1, Culture=neutral, PublicKeyToken=null, Dynamo detected that the dependency RevitAPI, Version=, Culture=neutral, PublicKeyToken=null was already loaded with an incompatiable version. It is likely that another Revit Addin has loaded this assembly, please try uninstalling other Addins, and starting Dynamo again. Dynamo may be unstable in this state.
It is likely one of the following assemblies loaded the incompatible version:

After that it lists what looks like a bunch of Revit API terms. I can provide if it would help, but I didn’t want to post a wall of text.

What’s weird to me is the message says “…Version=2018.0.0.1…” but I definitely have the latest version installed (2019.2.6). I even manually removed the old archi-lab package folder as suggested in this post. Does anyone have any other suggestions?

does dynamo give you a stack trace when it crashes?

@steezzen can you do a test for us - please navigate into your dynamo core folder inside programFiles/Dynamo/Dynamo Core /2/ViewExtensions/and remove the xml manifest file the libraryViewExtension - does dynamo crash now? I know the library will not show up.

Does this crash happen 100% of the time?

@Neal_Burnham @Racel_Williams fyi.

Thank you for your response Michael.
I moved the XML file out of the folder, and dynamo appears to no longer crash when opening the scripts. Tried opening multiple scripts and it never crashed.
Yes, the crash happened 100% of the time until I moved the XML file.
Dynamo was not giving me a stack trace, I just got the standard Revit crash window afterwards.


I did a full uninstall/reinstall, cleared the Dynamo AppData folder, and installed just the Clockwork package. I was able to load just fine. However, as soon as I start adding other packages, crashes start to occur again, but now loading scripts do not cause a crash 100% of the time. It’s kind of random now.
With Clockwork installed, the following lines appear in the Dynamo log files each time I load, crash or no crash. But when a crash does occur, these are the last few lines from the dynamo log file:

2018-10-17 15:40:31Z : Loading node definition for “Dynamo.CustomNodeInfo” from: H:\Support\Dynamo\Packages\Clockwork for Dynamo 2.x\dyf\Application.Version.dyf
2018-10-17 15:40:32Z : while loading node Application.Version we could not find a port for the retrunkey fullVersion at index 4
2018-10-17 15:40:32Z : Active view is now HOME VIEW

When I tried to install archi-lab again, Revit and dynamo immediately crashed as soon as the package was installed, and this is what the log file looked like:

2018-10-17 15:47:53Z : Saving C:\Users\sshowalter\AppData\Roaming\Dynamo\Dynamo Revit\backup\Center Room and Room Tags.dyn …
2018-10-17 15:47:53Z : Backup file is saved: C:\Users\sshowalter\AppData\Roaming\Dynamo\Dynamo Revit\backup\Center Room and Room Tags.dyn
2018-10-17 15:48:53Z : Saving C:\Users\sshowalter\AppData\Roaming\Dynamo\Dynamo Revit\backup\Center Room and Room Tags.dyn …
2018-10-17 15:48:53Z : Backup file is saved: C:\Users\sshowalter\AppData\Roaming\Dynamo\Dynamo Revit\backup\Center Room and Room Tags.dyn
2018-10-17 15:49:02Z : System.InvalidOperationException:
2018-10-17 15:49:02Z : There already exists an AlsoKnownAs mapping for Fill Pattern Targets.
2018-10-17 15:49:02Z :

Please let me know if there is any other information I can provide.

I have the exact same issue happening with Dynamo 2.0.1 and using the latest packages for archi lab and clockwork. I had a few scripts that would immediately crash dynamo and revit with the same log results as steezzen. I tried to pin point what was going on by making sure all my scripts were saved using the JSON format and it seemed to stop some scripts from crashing but others I would just make, save them, and then be unable to open again because they would crash. Getting rid of the library view extension seemed to allow me to open a script that was always failing to open.

EDIT: wanted to add that when I’m using Dyno browser to run the scripts they would run just fine. They would immediately crash when I tried to open them in dynamo and load the UI and all so it might be something with the libraryviewextension?

Do you happen to have the ParametricMonkey or BVN packages installed?

I think this is a bug in the libraryViewExtension as well - we have this tracked.

I do not have those installed. These are the ones I have installed.

I was updating all my packages on a remote computer in attempts to fix the crashing I’ve been experiencing and it didn’t help much. Then I has taken out all my packages and definitions and noticed the clockwork and archi lab would cause crashes once those were loaded and sometimes my custom definitions. I went through and updated all my custom definitions but I don’t know if maybe some helped cause issue because some were from archi lab and rhythm that were removed from the package so I copied it from a version where it did exist and updated it. I don’t think it should have caused conflict to the library view however but it might. Sounds like the team is aware of what’s going on.


I’d be willing to try any fixes y’all come up with.

I went to my Dynamo AppData files and I am not seeing how to move the XML file. I am not seeing an XML fineI am also crashing when I have clockwork and lunchbox packages installed.

I went to my Dynamo AppData files and I am not seeing how to move the XML file. I am not seeing an XML fineI am also crashing when I have clockwork and lunchbox packages installed. Where exactly was the XML file and how is it labeled?

path is not in appdata:
programFiles/Dynamo/Dynamo Core /2/ViewExtensions/

To be clear - we believe this bug does not have to do with Archilab and clockwork specifically. It’s a a race condition in the 2.x library, and is more likely to be hit with large packages.

1 Like

I hope it’s alright to respond to this conversation, as I’m having very similar issues! I’m new to Dynamo and am trying to run a script that I got from AU. It’ll “run completed with warnings”, so although it’s not crashing, it’s also not doing what it’s supposed to. I assume it’s because I have the same notification as the original poster (System.IO.FileLoadException, with the same text). It specifically calls out my Ideate and Unifi add-ins, that I’d really like to keep and not have to uninstall for Dynamo to work, as the solution suggests. I removed the libraryViewExtension.xml and uninstalled all older versions of Dynamo, but continue to have this problem. I only have the archi-lab, Bumblebee and Clockwork packages. Any ideas to help?

Hi @aharper22 I don’t think this is the same issue. This issue is about a crash. If you have some other incompatibility between some addins and your packages please start a new thread with all the details.

1 Like

Same issue here. I removed the xml file and my script opened up without crashing everything (which it wasn’t doing a week ago). However, although my script loads, I am missing all packages, including the built-in ones in the node-browser on the left. Completely blank.

I have BVN, Clockwork and ArchiLab packages installed (latest) and Dynamo 2.0.2

As with some other scripts that seemed to crash Dynamo + Revit, if I open a new blank script, then open the script I want that works. It feels like once all the packages are open in the session they’re happy to be applied to an existing script. I re-instated the xml file for this process.

@Michael_Kirschner2 i thought you guys got it fixed in 2.0.2?

it’s this PR:

(I believe 2.1)
2.0.2 was to support revit 2019.2 for the most part - as well as some security improvements.

Wow, I am seriously disappointed. So, we got an issue, that is consistently and reliably crashing everyone’s machines, and you guys won’t patch it up, instead just put it off until “next major release”.


You all realize that between Clockwork and there are well over 200,000+ installs. That’s pretty much everyone that is using Dynamo, and they are experiencing crashes left and right.

cc: @Zach_Kron