Archi-lab having issues loading on Dynamo for Revit 2022.1.2

I’m having issues installing archi-lab for Revit 2022.1.2, Dynamo 2.12. I’ve followed the steps to make sure I am installing the right package for the version of Revit, but still no luck.

This is the correct package for Revit 22, correct?

Thanks in advance.

That is correct. My guess is that you need to uninstall another version, which wouldn’t be updatable as the file will be in-use once you start Dynamo. Check for Archilab in your ‘manage packages’ dialog, and mark any there as deprecated, and then restart Revit and try installing again.

Hi @jacob.small - I’ve cleared out all of my packages on my AppData folder and I’m still not having any luck installing them. I’m going to check with some of my other users, but 2022.1.2 is having issues. Revit 2020 and 21 are not having issues. Do I need to uninstall Revit 22 and reinstall it?

it looks like you may be installing the package into a different package path than you expect. Please use the manage node and package paths dialog to show your package path order. You can try moving the %appData% path to the top.


Hi Michael - It looks like that was it. Now, one thing I’m curious about is the default path was at the top but was pointing to one folder shy of packages. I had to add the path to that folder which got it to work. Was there something that I may have done to cause the default location to land one folder short of the packages?



I think it will work with either packages or the root - but the %programData% folder wont load normal packages - I think the bug that it somehow gets moved to the top/ is the package install location is fixed in 2.13.


Thank you, is it possible to force these locations through the .ini file for Dynamo?

well the settings.xml file yes - atleast in your version you can alter the order in the settings file and it will be loaded. It gets more complex in later versions as to fix this bug I think certain paths are never allowed to be install locations no matter where they are located in the list. But in general yes, you can modify the settings file to change the order without needing to use the dynamo ui.