Trouble getting packages to load in Revit 2022/Dynamo

We just switched over to Revit 2022 and I’m having trouble getting packages to load. I have a script (that works fine in 2021) using a few packages, like Clockwork, Data-Shapes, Rhythm, and archi-lab.

So far, archi-lab is the one really giving me problems. At first, I loaded the script and it said several scripts were missing. I originally had Dynamo in 2022 pointing to the same package install location as 2021. So, I made a new folder for 2022 (Dynamo 2.12). I started with nothing in it and reopened Revit, Dynamo, and then the script. I went down the list of missing packages and installed the versions the script had used. That seems to have worked for all but archi-lab.

If I look in installed packages, archi-lab is there. So, I uninstalled it and restarted all apps. I then installed the latest version of archi-lab. It still won’t load. It doesn’t who in the Add-ons list on the left side of Dynamo either.

I have 3 Notifications. One letting me know that Python 2 based custom nodes will be deprecated, and two System.IO.FileLoadException errors. One for Rhythm and one for Autodesk.Forge.
I routinely had 13 of these errors all the time in 2021 and it all worked just fine. So, I don’t necessarily think these two errors are the issue.

Has anyone else had issues with archi-lab in Dynamo 2.12?


Check out this video: How to Install the Correct Version of the archi-lab Package in Dynamo for Revit - YouTube

1 Like

I just uninstalled archi-lab again, rebooted my machine, and then installed the latest version. Still won’t load into Dynamo. :frowning:

Okay. I’m going to do it that way and see what happens. Thanks.

That did it. I wish there was some standardized versioning syntax for all packages. It’s not always easy to tell which version should be used. :-/


1 Like