Add Shared Parameters to several categories into a project

Do you know if it is possible to add several Shared Parameters to several categories (e.g. Walls and Floors) at the same time using this node?

I do not know how to combine several categories into a list in order to feed the node. It gives me “NULL”.

@Kulkul I am not sure if you have solved it before.

Thank you in advance.

@alejandro.daras If you ignore the null value it works as expected. Follow the process below.

Thank you for the early answer @Kulkul ; however, it is not working yet.
I did exactly the same workflow as you but using my shared parameters file and the correct names for my parameters, without luck.

I am using Revit 2016 R2 with Dynamo 1.2, maybe the API is different and this node is written in order to work in Revit 2017. Any thoughts?

By the way, here I see that you set 3 parameters into WALLS (Watts, Uvalue, Thermal) and 3 different ones into FLOORS (Fractal, Flip, Finite), would it work setting the same parameters in both categories at the same time?

My main goal is to set a unique list of parameters into several categories simultaneously, is it possible?

Thank you in advance for all your help!!

Hi @alejandro.daras ,
do you already have your .txt containing the shared parameters?

Yes I do. It is selected in my project too.

Then I suggest you take a look at this workflow as an alternative :

you can download the .dyn in part 3 of the article.

1 Like

@alejandro.daras Yes you can set for both categories. Set Lacing to Shortest for Create.SharedParameter node.

[quote=“alejandro.daras, post:3, topic:10516”]
My main goal is to set a unique list of parameters into several categories simultaneously, is it possible?


Thanks for your help guys!!

@Kulkul now it’s partially working!! However, there is an issue that I cannot understand.
When I create a parameter using Parameter.CreateSharedParameter node and then I delete it (selecting my parameter by ID), I cannot create it again using Dynamo but I can create it using the UI.

Should I “deeply” remove my parameter? I thought it was completely removed when I deleted it by ID.

P.S.: I didn’t try Data-Shapes yet, but I will very soon @Mostafa_El_Ayoubi

Thanks again!!

@alejandro.daras You need to close the script. Open it again and then “Run”.

I’m having problems to get this script running. The first UI is working fine but the second won’t appear.

When having a closer look inside the Dynamo it shows the following Errors:

The UI Nodes for the Listview also seem to be a different version of the one showing on the documentation (


I found the Problem. I have been using Dynamo 1.3 instead of 2.0.
Did the update and it worked like a charm.