3D Background view no longer working


I am using Dynamo version, it seems that the 3D background view no longer works. Zoom to fit no longer does anything and the UCS grid is not viewable either. I checked in the “View” tab to make sure that it was ticked on.

I have re installed this version of Dynamo and the issue persists. Not sure why this is happening as it had been working fine until now.


I went through past forum posts and disabled my “Intel® HD Graphics 630” display adapter using the device manager on my system.

I am not a whiz with computers so I would still like some feedback to understand how/why this happened? It was never an issue and all of a sudden my background 3d preview disappeared. My specs are:

Window 10
GPU: Radeon RX 580 series (with radeon drivers installed)


Your system uses the less powerful graphics card for less demanding tasks like Paint or web browsing. For some reason Dynamo or system hasn’t switched graphics.

Hey there Tomasz,

I have actually come up with a new issue. In this instance it is to do with Rhino. It only works when my Intel HD Graphics is ENABLED. Which obviously means Dynamo no longer works. Do you know why that would be the case? Isn’t there a way to optimize so that each program uses the most compatible/powerful graphics driver?

I have posted also on the Rhino support forum but wouldn’t mind an answer here too.



First laptops with 2 GPUs came around Windows 7. It was all new back then and technology was a mess. I don’t know what triggers system to switch cards, but you definitely can:

  1. If you’re not using Windows 10, you should upgrade. W10 surely handles two graphics card better than W7.
  2. Install latest drivers. Try to find out what triggers cards to switch. (My laptop still rocks a single GPU, so I may be wrong here) There’s surely an option to force system to switch graphic card when certain application is run.
  3. Check all possible options for display modes in Rhino/Dynamo, sometimes changing graphics mode helps.
  4. Suck it up and switch drivers manually

Thanks for the reply. I actually am on a desktop, not sure if that changes anything. I also use windows 10 and have the latest drivers. Turns out, according to the Rhino forum the issue really originates there as AMD drivers are not very compatible with Rhino 5. They are aiming to fix this for Rhino 6. Looks like I will have to take your 4th piece of advice and suck it up :stuck_out_tongue_winking_eye:

Either way, I appreciate the feedback.