Dynamo 3d preview not working build

Hi guys, I am just doing some tutorials from DynamoPrimer at the moment and I made the change from 0.7 to 0.9 to get new packages.

I am currently doing the Python scripting section and in 0.9 I can’t actually get a 3D preview to work for the grids.

I had a look around on the forums but didn’t find anything directly related to 0.9

The Revit background is off, the render precision is high and as you can see from the image the watch 3D isn’t showing me anything.

Cheers in advance for any help guys and girls.


Can you check whether your 3D Background preview setting is ON or OFF?












Hi Ritesh,

Yes it is on. see the attached image below


Can you please go through this FAQ’s https://github.com/DynamoDS/Dynamo/wiki/Dynamo-FAQ

Also check whether your graph drivers updated or not.



Hi Jean-Luc, did you get it working? I encountered a similar problem before, and upgrading my graphic card did the trick for me. Hope this helps

Hello, I also cannot see my 3D background preview in Dynamo. Using version 0.9, with Windows 7, Revit 2016 R2, Graphics:Intel HD Graphics + NVIDIA GeForce GTX 780 running on a desktop computer. I’ve tried everything suggested in this forum (and in the FAQ), including making sure that my preview is on in Dynamo. Any other suggestions? I am excited about using Dynamo, but is seems less useful and harder to learn without being able to see the 3D in the background. I have no problems seeing the background at home on my laptop, but can’t get it to show on the desktop machine. Thanks, starr

I had the same issue, Win 10 64x, Dynamo 0.9, Revit 2016 running on a Asus laptop with dual graphics IntelHD 4000 and Nvidia 720m. The fix that worked for me was changing the preferred graphics to the Nvidia one, but this doesn’t fix the problem all the way. When I started dynamo i sometimes got a 3D Preview and sometimes not. But then I noticed that if I resize the Dynamo window make it a bit bigger then what it is in minimized form the 3D Preview appears. For some strange reason when pressing the maximize button the 3D Preview stops working (maybe Dynamo doesn’t like windows 10, idk). So basically I just had to resize the Dynamo window, until the 3D Preview appeared.

Never mind.

To set hight efficace for NVIDIA.and try again