3d background preview no available

hi everyone,
i have this big problem about 3d background preview and i didn’T find any solution.

I reinstalled older versions and the new ones, but nothing. i still have the problem.
I noticed that someone solved it, but for me nothing worked.
I realize that probably the problem is related to the graphic acceleration, but i don’t have any idea about how to fix it.
I hope someone could help me.
i have a notebook nvidia quadro m2000m and 32 gb ram.

First check this…

Then look at the first question here…

1 Like

yes i already done everything suggested. but i still have the same problem.
Actually i didn’t find the directX 9 version for windows10.

the only solution that i found was to disable the intel graphics card and now it works but anyway it says that i need to upgrade the drivers. I’ll not do it.

I do not have. Pls hepl me.

I do not!

Try setting NVIDIA control panel and Dynamo to use the “high performance NVIDIA processor”.

I have the same problem and I am not able to solve it. Can someone give me a hand? I use it with bootcamp and an AMD radeon pro 5500 graphics. Thanks in advance and greetings !!


I just change the graphics to maximum performance and it work fine

We have similar issue on one laptop and we use these solutions:

I’m having the same issue here apparently it has to do with the Intel processor and the Nvidia Graphics card, but I have dynamo on Revit. I really didn’t understand how to tweak the settings in order to make it work.

All I read is that there are some settings I need to change on the Nvidia Control Panel, but the Autodesk Revit does not provide further settings because everything is grayed out?

I’m not sure in what part should I tell Revit not to use the Nvidia Graphics Card. I also tried setting up the Global Settings under the Intel Processor. 3D preview is still not showing up.

Go to “configure surround, physX” and choose your graphic card as processor.
Then follow the steps from the Michael_Dengusiak above,
https://knowledge.autodesk.com/support/alias-products/troubleshooting/caas/sfdcarticles/sfdcarticles/Background-3D-preview-is-grayed-out-in-Dynamo-for-Alias.html ,
I have installed both the Alias Dynamo sample File and Direct3D Installer for Dynamo and it worked. Revit 2021 on Win 10.