0.8.1 Release Candidate available


#1

We are in the final stages of testing and critical bug fixing for the next stable release. Please take a look, and if you see something terrible, please jump up and down and make some noise. If you have been seeing a problem in daily builds and assuming it will be fixed by the time we release, check this build. If you still see it, it’s likely going out with that defect!

http://dyn-builds-data.s3-us-west-2.amazonaws.com/DynamoReleaseCandidateInstall0.8.1.exe

New functionality to pay particular attention to:
New Graphics pipeline: we have modernized our preview capabilities to take more advantage of your graphics hardware.
Color: Check out the Display.ByGeometryColor capabilities.
Grouping: Organize your graph
Excel: Improved handling of read and write, including more robust management of null values and ragged lists
Node Parameters in multi-select: Control the preview state of lots of nodes at once. Simple, but needed
Usablity improvments for node port tooltips
FamilyInstance.SetRotation!

One thing we are still tinkering with is “in-canvas” search, currently accessed through Shift-DoubleClick.

A more full description of new functionality and bug fixes will be coming. Thanks for your input!

-Dynamo team at ADSK


#2

Yes! In canvas search! Look forward to putting this through some test on Monday!


#3

I’ve got a strange behavior regarding the group. If I select the group and choose delete, everything is going well (I assume that this action should delete also the nodes of the group) but if I deleted the wrong group a I use the undo command I will get every time the following error:

An item with the same key has already been added.

at System.Collections.Generic.Dictionary2.Insert(TKey key, TValue value, Boolean add) at ProtoScript.Runners.ChangeSetComputer.GetDeltaAstListAdded(IEnumerable1 addedSubTrees)
at ProtoScript.Runners.ChangeSetComputer.GetDeltaASTList(GraphSyncData syncData)
at ProtoScript.Runners.LiveRunner.SynchronizeInternal(GraphSyncData syncData)
at ProtoScript.Runners.LiveRunner.UpdateGraph(GraphSyncData syncData)
at Dynamo.Core.Threading.AsyncTask.Execute()

Best regards,

Lucian


#4

The grouping feature looks splendid. I think was a must.

I’m wondering if the name of the group can be kept readable when we zoom out like an auto sizing behavior of the text.

Also, maybe we can have a large palette of colors.

I think these two are wishes, not something terrible. :slight_smile:

Regards,

Lucian

 


#5

dynamo 0.8.1 does not show geometryI’m using VMWare Fusion 7.1.1 (latest version) on a mac as a virtual machine for windows. I was able to use Dynamo 0.8.0 for Revit 2015 successfully, however, I can’t use any of the 0.8.1 (or 0.8.2 ) releases. The problem I encountered is that the preview of geometry just shows blank space. I don’t see a grid, and non of the geometry I created ( a simple sphere with centre 0,0,0 and a radius of 10). The Watch3D Node does not show geometry either. I think Autodesk does not officially support VMWare, however, it has worked just fine with regard to previous builds. I hope you guys can look in to it.

Best,

Jesse Mom


#6

Hey Jesse, I’m not sure if VMware supports the new graphics visualization(only supports hardware accel for direct x 9.0 c, not 10), parallels 10 currently does, but not with anti-aliasing.

 


#7

Thanks for the clarification Michael. Indeed, the latest version of VMWare Fusion does not support DirectX 10, too bad. That limits me to using older versions of Dynamo. Thanks anyway, and fingers crossed that VMWare will support newer versions of DirectX in the near future.

Jesse


#8

I got an issue with Package manager. was not here in regular 0.8

0.8.1  PM


#9

Hi Julien,

Is this a persistent issue for you with 0.8.1? I can’t reproduce it, but will try in some other environments.


#10

In-Canvas search is awesome. I’m saving so much screen estate :slight_smile:

I updated a few nodes without problem and created group without issue. Definitely LOVE the group feature. Much easier for reading

 

Thanks a lot for the update :slight_smile:


#11

I got no issue with 0.8 but never tried this with 0.8.1 before this release. will make another try tonight.


#12

same result with 0.8.1.1530 from daily build.


#13

Thanks Julien, I think we have a handle on the package issue, a fix is on the way for 0.8.1


#14

Hello Zach,

Whenever I start a Dynamo session, then close down Dynamo and fire it up again in the same Revit session I am faced with this error window:

2015-06-05_11-13-48

 

I don’t really see this as a problem but more as a tiny annoyance because after you close down the error message everything works as expected. At first I thought this was limited to my machine but then the same thing happened on a second computer with 0.75 pre-installed.


#15

Ok found a major bug. All conditional statements seem to be broken if the true and false inputs differ in length. The output is limited to the length of the shortest input. Can anybody else replicate this?

2015-06-05_17-16-08


#16

Hello Dimitar,

I have logged MAGN-7581 for internal tracking.

Thanks for reporting.

Keep using Dynamo!!!

Thanks,

Ritesh


#17

Hi Dimitar,

So, the change you are seeing is this:

2015-06-06_0802

This is actually part of an intential change to IF node behavior. Please take a look at this conversation:

Basically, we have made the IF node behave in a more robust manner for lists, see below

2015-06-06_0813

If you still want to get the “switch” behavior that you had in 0.8.0, you can still use the formula node with lacing set to Longest. Does that make sense?

2015-06-06_0835

 


#18

Hi Zach,

Thank you for the explanation. I went through the pull request and I can see that there are a lot of merits to the new way of handling things. So the new functionality tries to add lacing to the If function, similar to combining the original If node with one of the List.Combine nodes.

Tho it seems like the formula node set to longest lacing is not the ideal alternative when handling mismatched lists and the only way to bring the old “switch” functionality back is to use imperative code as per Luke Church’s suggestion(which might not be a good approach for new users).

2015-06-07_13-27-57

How about the following: could you evaluate the test input - if it’s a single input, use the old “switch” functionality, if it’s a list of booleans, use the new improved functionality. That way we can have the best of both worlds.


#19

When using cross window select on groups it does select the entire first group, but only selects the nodes in the window of other groups. I’ve made a video to clarify:

Not sure if it’s meant to be that way, but I think it should get the all the groups that intersect with the cross window selection.

 

Also, the outputs of the CBN aren’t lining up with the connectors:

Dynamo 0.8.1RC bug 2


#20

Using 0.8.1 via Revit, I’ve crashed a couple of times (saved right before attempting run that crashed). Re-launch Dynamo and I can’t open the file I saved. Crashes have happened with previous versions, but I’ve always been able to re-open. Thoughts?