Warning: Data.ExportExcel operation failed

New work PC, wondered why a script (that i use regularly) was completing without opening the excel file at the end.

Seems the Data.ExportExcel node is giving a rather helpfully vague error message.
Same message seen here using the sample “Export Data to Excel” script.

The machine is a brand new item, fresh install of current windows 10 and office365 (both x64)
all works fine on other machines in the office.

(my script uses a combination of bumblebee write to excel nodes and the ExportExcel nodes - as I like the fact the ExportExcel opens the file for me afterwards)

Not sure, but your Startcol/row…is feeding a double and not integer, just a thought, without i really can see whats goin on, try to upload your dataset as well then easier to give a help :wink:

This script is just the sample script that comes with Dynamo.
just a screen shot of the final section with the error on the node.

Script is available to all via the samples section of the dynamo home screen
image

1 Like

hehehe…then is @JacobSmall we should call… :heart_eyes:

1 Like

Having read:

Which mentions this error cropping up if there is a version incompatibility between a 32bit and 64bit installation… (tho i know that it was the 64bit office was installed)

Currently I’m trying - restore PC to before Office was installed, and reinstalling Office.
(Having already tried uninstalling and reinstalling office (which didn’t seem to actually uninstall office as I was still able to open excel documents once office was uninstalled)

which office version is it ?

has fixed the issue.

1 Like

@lordsummerisle …Nice to hear :grinning:

Hi, any idea about why this is happening and another solution?
IT department said that they are not going to restore to a previous point all Revit Technician computers (more than 15) and uninstall and install back MS Office.

It is quite annoying this.

Thanks

I have a new build PC and office was installed as part of the setup but I have the same problem unable to export to excel. I can to a csv file.

I have this issue now also. Our company has always had 32-bit Office and 64-bit Windows and the Excel exporter/importer has always worked for me until now. Our IT department recently pushed out an Office update related to security issues. So, the issue must be more than just 32 vs 64 bit. I hope I can get this resolved soon because I use the Excel tools quite often.

My Excel version is 2102 (Build 13801.21004 Click-to-Run)