Warning: Data.ImportExcel operation failed. Excel is not installed

Hey guys I am using Revit 19.2 Office 365 and Dynamo version 2.0.3 and while running a script, which requires to pull data from excel, I am getting the following error:

“Warning: Data.ImportExcel operation failed.
Excel is not installed.”

I am using a new lap top but the softwares are exactly the same as on the old lap top and the routine works on the other one. Does anybody know why I am getting this error and how to solve it?

Try reinstalling Office.

I tried that Tomasz, but no cigar. Any other ideas?

What version of excel do you have installed?
Have you opened excel manually and if so were there any issues?
Is it 64 bit or 32?
Newer than 2010? Older?
Full office or a ‘starter’ version with limited API access?

@JacobSmall,
it is full version of Office 365, 64b.
No issues when I open Excel manually, also the script works on a different station with same version of software.

I think it may be an issue with the 64 but excel. See here: https://github.com/DynamoDS/DynamoRevit/issues/1950

@JacobSmall,

I still get the same error.

Warning: Data.ImportExcel operation failed.
Excel is not installed.

Try a 32 bit version of excel?

@JacobSmall, testing the 32 bit version, will post an update shortly.

1 Like

@JacobSmall still no luck. I keep getting the same error:

“Warning: Data.ImportExcel operation failed.
Excel is not installed.”

I have unistalled, deactivated:reactivated Microsoft Office. Any further tips would be greatly appreciated.

Oh man… at this point my next guess is to check the registry for old entries for excel after the uninstall, but I’m at a loss from here…

Best to move to the GitHub and create an issue there (link above should get you started on doing so).

FYI @Michael_Kirschner2

@JacobSmall, Thank you for trying. I think the issue was a Data.Import.Excel Node.I replaced it with ExcelFile.Read node and it has imported the data. It works both on 64 and 32 bit versions of excel.
It also effectively proved that it was not a excel version incomatibility.

Thank you all for you time and your feedback.

Hi,
I am facing same issue.
In which package shall i get node ‘ExcelFile.Read’?
Kindly advice.

Thank you.

Did you find the node?

Kindly refer below post.

When I faced same type of issue,Our IT guy uninstalled ‘Office 365’ then deleted registry key as well & then install ‘Office 365’.
Now Excel working properly with Dynamo.

If you don’t have Dynamo 2.0 you may say ImportExcel instead. Search ‘excel’ and which to use should be clear.