Wall.ByFace Node reporting nulls

In version 1.3.1; the Wall.ByFace node appears to have a problem that I can’t get past regarding either the locationLine input or the surface input. In either case, the node reports “nulls” when these inputs appear to be satisfied correctly. Is there something I’m not understanding or does this node have a bug that needs to be reported?

I see from the following post, Create Walls and Floors from Curves (or surfaces), that this node only works with Mass geometry? Huh? That’s a little silly (@system) Autodesk. If this is true, can this be corrected to work the way it should?

This isn’t a bug - it is behaving the same way as it would by using the Wall By Face command within Revit itself. As an alternative you can use the node Wall.ByProfile from the package Wombat Dynamo. Just get the perimeter curves of your Dynamo surface to use as the profile

Thanks for responding. I had replied to my own post with the same understanding. It would be better if this node responded to Dynamo geometry in my opinion. If this is meant to function with Revit masses, then the node should state as such. The only “bug” is that the description is misleading in the node itself. Cheers.

This bug does persist even when selecting the faces of a mass directly. Does anyone have any insight into whether there is another function node to perform this operation? Or is this a known issue?

I just did a test with a simple Mass form and it worked ok…
I ran it by manually selecting the face using select faces, and by replicating your workflow.
Maybe it is something to do with the Mass you are selecting?

For this test I had used a mass provided by the Dynamo Primer practice files. I can say that the practice file provides a project with an in-place mass family. Perhaps this node only functions with loaded conceptual mass families and not in-place masses? Still seems like something wrong with the node.

I did my testing on an in-place mass? Worked no problem.
I also wonder about some complex geometry having flipped surfaces, like when you import models for rendering and faces are flipped internally and you have to transpose them for material application?

I tried recreating the mass as family and the node still does not function in 1.3.1 as far as I can tell. What version of Dynamo are you running? Perhaps Autodesk repaired the glitch in the intervening builds?

Dynamo 1.3.2

ah ha. I will need to try a later version to see if that resolves it. Thanks so much for your replies @Scott_Crichton.

On a similar note, l have a number of points, which l have then created a best fit circle, then extruded as a surface, yet this surface is not recognised by Wall.ByFace. Why not?


I am afraid the other users of this post already found out why!

Many thanks.

I think the highlighted is the issue.