Using Dynamo to place Mechanical Families

Hi everyone,

I’ve been playing around trying to use Dynamo to place Mechanical Families. I’ve tried the clockwork and archi-lab node ‘FamilyInstance.ByPointInView’ and similar, but can only get this to work with detail items, whenever I select a mechanical family I get nothing.

I’ve read as much as I can find on the internet but can’t find anything conclusive saying this is/isn’t possible, so I’m stumped. I don’t want to give it up already if I’m missing something obvious. Has anyone tried this, and if so can anyone point me in the right direction?


Hi @Liam_Alsop

Place new family instance each run

Hi Kulkul,

Thanks for the link, that’s pretty useful.

However I’m stuck at a stage before that. I can only place certain families using this node, specifically I can’t place Mechanical Equipment. Has anyone succeeded doing that?


@Liam_Alsop What are you trying to place? It would be better if you can show us entire graph of your work or drop some files here. It works from my side. I placed mechanical equipment and it is placing.

Sorry, I tried adding screenshots and was limited to just 1 per post. In this instance I’m trying to place a fan family, yesterday I was trying with a FCU family.

When I try with other objects, in this case a detail item, it works:

It’s very hit and miss, of all of the families loading only a handful will actually be placed by this script

Which version of Dynamo your using?

Dynamo 1.1

download and install latest dynamo version 1.2 from here and try my above solution Using Dynamo to place Mechanical Families

Ok, will do, downloading it now. I currently get this warning running your solution (in 1.1), regardless of the family I use, and whether or not the point coordinates are connected up.

Try this:

Still nothing:

The lower clode block runs, but still only for a few families, not all

I’d suggest that some of the families are hosted i.e cannot be placed by point/level


Thanks for the input Andrew,

I thought this, but the families are only hosted By Level, they can be places anywhere on the level though :

And we are giving them a Level input so I didn’t think this should be an issue? I could well be wrong though

Kulkul, sorry, I was being very stupid! I was still using the View input not Level input when I tried the code block you suggested.

Thank you for the help, I’ll let you know how I get on if I manage to do something useful!


Excuse me for the dumb questione but are you working in a revit project or family?
If you are working in a project could you post a screenshot of the error FamilyInstanec.ByPointAndLevel gives you with these problematic elements? Thanks

Hi Greg,

I was working in a project, you can see the error in post #9. I was sending a view input into the FamilyInstance.ByPointAndLevel node, when it wanted a level input.