Unable to build cloned Dynamo Repos - Missing dll files

Hey forum, i would start by saying, that if i violate some rules, or give a bad description, that i am inexperienced and sorry.

My problem: I am unable to build a cloned repository of Dynamo, found on: https://github.com/DynamoDS/Dynamo. A list of the errors can be found in bottom. Most errors seem to be issues with missing files such as dll’s:

When i try to follow the path, where the dll’s should be, i cant find them, hence i cant recreate the references. Am i missing something here? I only cloned the repos from the git, and tried building it, since i need the dll’s for the Revit Testing Framework.

What i have tried:

  • Finding the dll’s elsewhere(maybe in another folder)
  • recopying the repository
  • reading the README file
  • Looking for others with same issue, but couldent find any, so maybe im phrasing my issue wrong

I am sorry, that i dont have more information, i am feeling quite stranded with this issue

Are you using the latest Nugets Package? If not then make sure you do.


I did this, and while i did indeed lack the latest package, it did not resolve my issue, as the files are still not present in the respective folders, however i was able to do this in another solution, where i could more easily find the files. After doing this i simply copied it over into the debug folder, and now alot of my errors have subsided. There are however still some meta data missing, which is featured below. I do however see that all the missing data, is being looked for in another folder, than the one i pasted into, so if i continue to lack a delicate approach, i might try and copy into it also.

Currently missing dll’s: