Dynamo sandbox doesn't read the .dlls but dynamo revit does


I need to use sandbox to be able to debug my code. I have a bunch of .dlls in in the $(AppData)\Dynamo\Dynamo Revit\1.3\packages\$(MyProject)\bin\ and $(AppData)\Dynamo\Dynamo Core\1.3\packages\$(MyProject)\bin\ folders and they work perfectly fine for when I run dynamo revit, but when I run dynamo sandbox my components don’s show up. I’ve tried to download packages and they work in both ds revit and ds sandbox, only my local project that doesn’t work in the sand box mode. The files in the \bin\ are exactly the same and they don’t have any blocks on them.

Any idea why this may be?

does your dll reference the revit API or the DynamoRevit API?

1 Like

Hi Michael!

Only the Dynamo API. Nothing with revit in it.


are these valid packages? sandbox will only load packages from Dynamo Core not from Dynamo Revit folder.

do you have a package.json file in your project folder?

Yes, all the build files are in both the dynamo revit and dynamo core folders and I have a pkg.json file in both. These are the nuggets:

do you see any errors in the console?
what package paths do you have in your manage node and package path settings window?

Not sure what you mean by “errors in the console”. This in the map I get to if I click "show root dictionary for the toolkit if i then click into the \bin\ folder:

On the View menu, activate Show Console or press Ctrl+Shift+Up to display the console @Michael_Kirschner2 mentions. When Dynamo starts it prints all errors found when loading the packages, something like the below:

If your package is not loading properly, an exception would be shown there.

1 Like

Thanks for your reply @alvpickmans! So, this are the messages that I get. The first pic is the dynamo settings.XML showing the folder that dynamo is loading the packages from which seems to be right. The second one is the show console. Right now its complaining about not being able to load AdInManager.dll, but if i take that away it just keeps complaining about not being able to load in some other .dll in the myProject folder. The AdInManager.dll in this case IS in the folder and it’s not blocked. Might still be that one of its dependencies is missing, but then its strange that it works for dynamo revit.

I think that dll requies the revitapi, this won’t load without revit. (my guess) try running depends.exe on it if you are not sure.

@Michael_Kirschner2 Thanks! You are probably right. Even if the .dlls doesn’t reference the revit API directly, there might be a reference to another file that references it. I’ll have a look and comment again when I know. Thanks a lot! :slight_smile:

@Michael_Kirschner2 @alvpickmans Thanks a lot for all the help guys! The problem was indeed that some of the .dlls referenced other .dlls that referenced the revit API.

1 Like