Problems building Dynamo from source

Hello, I am currently trying to build a dynamo from source following this guide and ran into a few problems building the project.
When building the project I am confronted with 1528 errors and 2632 warnings. Looking warily at them it seems like they all occur because some projects within the solution could not get built and therefore the references to those are missing.
One of those projects is the DynamoCoreWpfTest project. This project is missing some references (as seen in the image) which are the SharpDX.D3DCompiler and ShaprDXDirect2D1 all the other SharpDX references were found. All other projects that could not be built are also missing those references.

After removing the references and adding them again by hand I am able to build the project but I cannot run any unit tests because:

NUnit couldn’t find any tests in D:\Projekte\Dynamo\Dynamo\bin\AnyCPU\Debug\DSCoreNodesTests.dll

That process was explained here:

Apologies for a rant portion of the post. Just scroll all the way down where I give steps to building the repo from source.

Your issue specifically, is that you pulled the repo, and since it had missing references, you swapped them out manually. That’s a no no. You need to build it right away, and all missing references would be resolved via Nuget Package Manager.

There are also instructions on their repo:


Just to be sure I tried it again, cloned the repository (just dynamo, not dynamoRevit), opened the project and immediatly built it, without adding references manually (as I think I did before) and got the same errors as in the picture above.

Hi, thanks for all the help :),
I tried the nuget package restore and got the message that all packages are already installed

Next, I looked into the project file and found out that the SharpDX.dll should be in the same folder as the missing SharpDX.D3DCompiler.dll. In my case, SharpDX.dll is in the following directory:

C:\Program Files (x86)\MonoGame\v3.0\Assemblies\Windows8

But SharpDX.D3DCompiler.dll is not. Did i miss to install something? I did install DirectX from the given folder in the repository. The location seems a little bit odd to me because i did not open the mono solution.

CC: @Michael_Kirschner2


I would just try rebuilding a few times (not rebuild - but build command) there are some post build copy steps that might not complete the first time you build.

I’ve never had to run the dx installer in the repo to build - and I routinely use clean vms which one are you referring to?

also you can try deleting your packages folder in the repo to force NuGet to reload, but you might also need to clear your nuget cache if it refuses to get the correct packages.