Trying to use Python with 2019 date modified

I have been using this script for a while now without this issue. I comb my network for Revit files and then get the date modified. As soon as I added a 2019 Revit project to my list of files, my python script falls into the except and returns “failed”. I’m not sure how to update to incorporate this. I am using Dynamo 2.0.1

Thank you for any assistance or tips.

Current Link and Central Model Status 2.0.dyn (76.9 KB)

Have you tried printing the error? It is hard to say where it failed because it just skips any errors.

At the except:, change it to:

	except Exception, e:

and the e will display the error you had. Might be easier to fix that way.

1 Like

I tried that and returned the message “Failed to extract basic file information”

This only happens to my one 2019 project. All other years work just fine.

Thank you.

Can you post the project? (I’m thinking possible corruption or a lack of other basic feature).

Current Link and Central Model Status 2.0.dyn (76.9 KB)

Here is the project.

I meant the revit project. I’ll test the dyn with one of my files though.

I open a blank project. Its the default Revit Template. The script then just combs our network drive. Could the default templates be corrupt?

I’m referring to the Revit 2019 file which is breaking your python. I’m testing something now.

OOhhhh. Got it now. I can provide it if needed.

What version of Dynamo are you using to run the graph? Remember 2018 Revit can’t read 2019 Revit files. :wink:

That was it. Very sorry for the trouble. Go to know.

Please mark a post as a solution so others don’t suffer the same fate. :slight_smile: