Script working in my PC but not in other from a share drive

Hi all,
I have been trying to incorporate the scripts I have generated into my company’s workflow but when trying to run it from anyone else’s computer an error message pops up saying the file is corrupted and it does not run. My colleagues are using the same Revit and Dynamo so I don’t know what am I doing wrong.
Should I save the file in a different way/extension so they can run it too?

PS: I have tried to send them the .dyn as well as placing it in the server and running it from there and neither way has worked so far and I have also tried in several machines.

This is the textbook behavior of your system having Dynamo 2.0 and the colleagues having Dynamo 1.3 or older in Revit 2019 or earlier. Can you confirm that they are launching Dynamo 2.0? If they are trying 2.0 can you post a sample dyn so we can review?

@JacobSmall my colleagues have the same Revit and Dynamo I have (2.0) :thinking:
Sample attached.
DisallowJoinsOnCurtainWalls-OnViewOnly.dyn (7.7 KB)

placing the dyn on the server might not work as there is a limit as to how big a hard drive can be for dynamo to work from.

are there any error messages that comes up??

@Tom_Kunsman No error massages a part from the one when trying to open the dyn “corrupted file”

The graph opens fine for me in Dynamo 2.0+, but the error shows up in 1.3 and prior (as expected).

Have someone restart their cpu, open Revit 2019, launch Dynamo, open the graph, and get the error message, close Dynamo, close revit, and then get their most recent Dynamo log from:
C:\Users*USERNAME*\AppData\Roaming\Dynamo\Dynamo Revit\2.0\Logs

1 Like

Are your co-workers using the Dynamo Player and is Dynamo 1.3 also installed on their PC?

Remove the 1.3 install or get rid of the Revit20xx folder in ProgramFiles/Dynamo/DynamoRevit/1.3

@JacobSmall we haven’t been able to replicate the issue nor produced the Logs as the 2.0 folder was not present. However, we have been able to solve the issue by uninstalling Dynamo 2.0 and reinstalling it again. It might have been a wrongly installed Dynamo or something.
Everyone thanks for the assist though.

1 Like

That’d do it - perhaps Dynamo was installed before Revit?

1 Like