Trouble sharing script with co-worker


#1

I have a very simple script which creates worksets and it works fine for me. I sent it to a co-worker to use and when he runs the script, nothing happens. He doesn’t get any error messages and no new worksets are created. I’ve ensured we are both using the same version of Dynamo and have the same packages installed. Has anybody experienced this before? What am I missing?


#2

Is this the same Revit project or are the two of you working in different models trying this?


#3

We’ve tried both. Earlier we were in the same model. He ran it and it did nothing. I ran it and it worked.


#4

Have him send a screenshot of the file after he runs it. Also upload the DYN for troubleshooting reasons.


#5

And check if he opened Dynamo after opening the project and not before


#6

A screenshot of the workset dialog would also be nice, after the successful run of course.


#7

Here is the script.Model Setup_Worksets.dyn (8.0 KB)


#8

Here is my Worksets window, before and after running the script.


#9

Mystery solved! It turns out we had different versions of Iron Python installed. I had 2.7.3 and he had 2.7.6.3. We both uninstalled Dynamo and Iron Python and then reinstalled Dynamo. Doing that installed Iron Python 2.7.3. The script works for both of us now.