Revit / Dynamo loading package that isnt installed and then failing to run

I have a Dynamo script that opens an excel file first. We use archi-lab 2020.23.13 with it. When I run the script it now fails saying “conflict with a dependency” “While loading assembly archilab, Version=2018.0.0.1,”

I have never installed this version and have uninstalled all packages reinstalled them tried removing add-ins baring RTV, Navisworks and Bluebeam addins and still cant find the problem. The last package I installed before it broke was Bluebeam 2020 but i cant find anything there… . My machine is the only one affected. Has anyone else encountered this before? A full uninstall reinstall will likely just recreate the problem. I have added the journal and a screen shot of the warnings popping up.

Im using Revit 2020 and Dynamo 2.3

Check your node and package paths to see if there is a version of archilab in an added directory (ie one version of the the package from the office standard packages on the network or a shared C drive location, while your packages are loading an conflict from your local user directory).

Also be sure you have the right Archilab version for your Revit build. For Revit 2020 you want an Archi-lab build ending in 2020 per the package notes. @john_pierson has a great video highlighting this here: How to Install the Correct Version of the archi-lab Package for Dynamo - YouTube

1 Like

Cheers. No no other office standard package requires it and i am the only person affected…
I have checked all these locations trying to uninstall test reinstall etc.

C:\Program Files\Autodesk\Revit 2020\AddIns
C:\ProgramData\Autodesk\Revit\Addins\2020
C:\Users\mccormicka\AppData\Roaming\Autodesk\Revit\Addins\2020
and
C:\Users\mccormicka\AppData\Roaming\Dynamo\Dynamo Revit\2.3\packages where I have uninstalled and reinstalled the packages a couple of times now.

Not sure how can only assume a product did a software update and this is working again.