The curves do not form a closed contiguous loop although it is closed

Hello everyone.

I wish you all are doing well. Attached you find a DWG file with a closed polycurve inside of it.

Using *“Floor.ByOutlineTypeAndLevel” in dynamo (after importing the dwg into Revit) I get teh error: “The curves do not form a closed contiguous loop.” even it’s closed.

Does any one have an idea? I tried also “PolyCurve.CloseWithLine” also as described by #Alisder_Brown hier.

floors.dwg (33.8 KB)


image
It worked for me by this way but using direct the polycurve in CAD file not working. Maybe it’s about lines sequence which formatted the polyline.

1 Like

Hi,

thank you for your quick reply. But I don’t want to take the curves apart and then assemble them together.

The reason is that I have a dwg with about hundred of such polycurves, each of them on a separate layer.

So I must use "Floor.ByOutlineTypeAndLevel”.

Among about hundred polycurves only three don’t work. I can’t determine why because they are almost similar to each other. I picket out one of those which don’t work and put it in this dwg for the sake of simplicity…

Thank you anyway.

Keep in mind it must also be a single closed contiguous loop. The API does not currently support multiple loops in any sketch editor (that I’m aware of anyway).

With that said, I think @ingenieroahmad is correct in that the curve order is probably the issue. It shouldn’t be too hard to recreate your polycurves in Dynamo with @ingenieroahmad’s solution.

3 Likes

I’m running into a similar issue. I have used topologic to generate polycurves defining inner and outer loops of a surface. All the polycurves register as ‘closed’, but one of them does not register as contiguous when i convert it to CurveLoop in the API.

I’ve tried ‘exploding’ and rebuilding the polycurves with Polycurve.Curves → PolyCurve.ByJoinedCurves, but this seems sort of redundant?