TextNote.SetText turns text bold

I wrote a simple definition that would allow me to mass replace certain strings of a text note in a view. When I run it though, all of the text notes turn bold. It isn’t the type that gets bold, the text within the note is.

I have tried to go back through the nodes to find out where this happens but without luck. One weird thing I noticed was that this doesn’t occur if I add a ToUpper node(Rhythm) before the SetText node. I would use this as a workaround(ToUpper -> ToLower) but I don’t want to lose single capital letters within the notes. Ideas?

ReplaceText.dyn (19.8 KB)

The OOTB method is probably doing that because they are not using the Formatted Text Option in the API.



I would suggest opening a GitHub issue here and reference this post for them.

Also, without seeing your file or lists, I can guess that maybe your lists are getting jagged and one text note’s property (bold) is carrying over maybe.

I’ve been testing this in a clean Revit file containing just 3 identical text notes so I know my lists are fine. I’ve also tried a bunch of different text note types and properties but nothing makes a difference. The similar node from the Clockwork package produced the same result as well.

I’ll post an issue on GitHub about it. Thank you.