Syncing server not running

I have both revit 2019 and 2020, and both of them are running in different dynamo core. Revit 2019 is using core 1.x and Revit 202 is using core 2.x
My problem is when im going to search packages in dynamo core 2.x it always fails to display any packages in search list, but when i search packages in dynamo core 1.x it can display all packages in the search list. is there any conflict between both core or what is the problem and how to solve this issue ?
thanks for your advice.


please make sure you are using the latest Revit 2019 and 2020 build and patches.
What Dynamo version are you running in 2020? Have you modified your installation at all?

Hi @Michael_Kirschner2
in my revit 2019 ( 20180328_1600(x64)) the dynamo is below

above this can sync the server and get those packages in the list

in my revit 2020 ( 20190412_1200 (x64) 2020.0.1) the dynamo is below

above this cant sync the server and get those packages in the list, so I only can download manually thru and extract the file into the designated folder to make it display in dynamo 2.1


do you have any extra addins installed in Revit 2020?

Hi @Michael_Kirschner2
I only have screencast addin in revit 2020

can you please try removing it temporarily and restarting revit and dynamo.

Hi @Michael_Kirschner2
I dont think it because of screencast bcoz this issue is already found in yesterday, and the screencast was just installed awhile ago before yesterday. Just now I also try to download this version dynamocore 2.5 :

I extracted to this folder :
C:\Program Files\Dynamo\Dynamo Revit

when I open this sandbox.exe file (dynamocore 2.5) as standaone it is working fine with search packages. but unfortunately this version is still not work under revit 2020, the revit 2020 is still open previous dynamocore 2.1, the problem if I uninstall dynamocore 2.1 and replace with dynamocore 2.5 maybe can be solved the issue… but I dont know where to locate properly for that dynamorcore 2.5 (extract to which folder) to make it run under revit 2020

I cannot reproduce this when using 2020 locally, are you on any kind of proxy network? Can you try using a different network as a test? When did this issue start occurring? Was search ever working in 2020?

One thing is very weird for me here… I already uninstall dynamo core 2.1 and also manually delete all the file and empty recycle bin in system folder. but when i reopen revit 2020 then open dynamo, but it is still using dynamocoreruntime 2.1 and not running under 2.5 version as expected. Again still can not use search package again under 2.1 version… it didnt appear search packages term and use opening as seen in 2.5 version.
I also try to open individually that 2.5 sandbox version.
I have recorded all my process thru a video as attached in this link :

Please have a look and see more detail what step did I miss. please correct me. thanks buddy

ah, if you can see dynamo core 2.1 in the control panel (or could) then you must have installed it manually from a daily build or have it from another product (maybe advanced steel?) -

I would get rid of any trace of the daily build if you can.

DynamoCore is now shipped with Revit 2020 and up and the core version can no longer be switched out like an addin using the installer. Those are only supported in 2017-2019.

So it makes sense you still see 2.1 since it comes with 2020 - can you try removing the advanced steel addin?

Also, at first I thought this might have to do with TLS changes - but that should result in a failure immediately upon searching, this looks like something else.

I would ask that you try just 2020 on a clean machine without studio or advanced steel to see if theres some conflict occurring.

1 Like

yihaaaa… :slight_smile:
finally i can use both version, i mean 1.3 for 2019 and 2.1 for 2020. firstly I uninstalled totally all dynamo core version and to keep it stay clean I even re-delete and empty bin, then I only reinstall core 1.34 for revit 2019 and amazingly I dont even reinstall 2.1 version for revit 2020, i just gave it a try to open revit 2020 and see that dynamo icon still in the manage ribbon, I open it again, and luckily this time search packages work perfectly, maybe this 2.1 version already came in one bundle built-in item in revit 2020 student version. the only issue is I still cant figure out how to make 2.5 version (daily build version) to replace current 2.1 built in version in revit. but, as long as 2.1 can work perfectly then should be no problem to keep using it :rofl:

well, thanks for your valuable time and effort to keep advice me… im very appreciated on your kindness help.
im a newbie for dynamo, just learn this from 0 from youtube tutorial. hopefully one day i can use it to create any organic form modeling… it looks great !

Have a nice day, buddy…


Hello Archidea970!

Just a quick note about this point:

the only issue is I still cant figure out how to make 2.5 version (daily build version) to replace current 2.1 built in version in revit.

In Revit 2020, you will only be able to have Dynamo 2.1 as it’s now considered a feature rather than a plug-in as shown in the blog link.

When Revit 2020.1 (Their point release) ships, it will have a later version of Dynamo :slight_smile: We, the Dynamo team, are releasing multiple Dynamo Core versions per quarter that will be running ahead of the host integrations that you can get Dynamo inside of (Such as Revit, Civil 3D, Alias, FormIt etc.) and you can access the new features in Dynamo Sandbox in real-time.

The daily-builds are inherently buggy and meant as a way for users to give feedback, but there are also stable Dynamo Sandbox builds available on that is how you access stand-alone Dynamo.


Hi @solamour
Thanks for your nice info. well noted.

1 Like

Hi, i have simular problem.
I did a clean install winows 10 pro.
installed the latest revit 2019. (and nothing else on it)
Dynamo Core and Revit. online package search window does not show any packages. (looks like there is no connection)
uptdated Dynamo to Revit and Core by clicking the green cloud at the right upper corner in Dynamo. (i did not do anything else)
same result. nothing is showing up in the package search window.

I have a other laptop running 2019 revit with dynamo core dynamo revit this runs fine. the package search makes connection and no problem. on this same laptop with the same revit 2019 and dynamo core i am not able use the package search functie. (looks like it does not make a connection.

I am teaching on a university of applied science, classes stat in 9 days. what to do?

Best regards Roland

install the patch specified here for your Revit version:


For revit 2019 you may try to uninstall any existing dynamo and leftover, then reinstall dynamo core runtime 1.34 , this version can use in standalone autodesk dynamo and also revit 2019. This is what i did it before.

thanks for your positive intentions but… nope this does not do the trick.
it’s a bit embarrassing for autodesk.
this should work flawless. a clean installed windows 10 HP zbook and the only thing that is installed is revit 2019.

i’ll give this a go tommorow morning. :slight_smile: thanks for your reply, i will let you know.
best regards Roland

you need to install the latest revit patches as linked in the AKN article. What version of 2019 are you using?

Dear Michael, i’m realy not able to find any patches to update other than through my autodesk account. non of them have a positive result. are you able to send me a link to the proper patches?