Study preview doesn't change

Hello! :grinning:
I am a student and I am doing research using Revit Dynamo.
My research involves “Random Generation of Floor Plans”.
So, I was planning to use the Generative Design feature to work on my research, but I ran into a problem.
Even though the variables were changing, the preview and output of the Study were all the same.
I have tried to investigate this problem but could not find a solution, so I am asking this question.
What exactly is the problem that is affecting the output?
If there is any information missing, please ask me!

PS: I am a new user and could only insert one media item. Could you please use the following Google Drive link to access the Dynamo files and images? My apologies.
This text is through a translation application.

Generative design files being created have been uploaded to Google Drive

Looks like it should work, and things run clean on my system.

What settings are you using in Generative Design? If you try a “random” run for 40 solutions do you get 40 of the same value?

1 Like

Thanks for your reply!
My research is done at a university. Therefore, the PC I am using has some limitations and the version of Revit is a bit old (Revit 2022).
This topic was created when I was stuck at the university, but when I installed Revit2023 on my own PC at home and ran the same file, I was able to confirm that it worked fine!
Sorry for my premature question…
I will try to upgrade the version of Revit used at the university to handle this as well.
Thank you very much for your answer and for confirming that it works!

1 Like