Outputs/Preview not coming through in Generative Design

I’ve been trying to run a view analysis routine through Dynamo/Gen Design in Revit 2021. No custom nodes being used, but for some reason the study always fails to provide the outputs to me as filters/results in my study when run. Likewise I can’t see preview geometry in the thumbnails - it’s just empty.

I’ve looked at the script in Sandbox and aside from the geometry nodes it seems to all be accounted for, usually the advice seems to have been to do this.

I’ve attached the model and script with inputs/outputs set already, if anyone is able to review and let me know where I’m going wrong I’d be grateful - bit stumped here. I’m presenting a webinar comparing Rhino Inside to Dynamo’s capabilities and I’d hate for Galapagos to knock out Generative Design this hard in my findings!


View and yield analysis.dyn (78.5 KB) Test project.rvt (1.5 MB)

@Lilli_Smith FYI

Hi @GavinCrump - does your graph interact with Revit? If so are you using the remember nodes to save that data so that it’s present when the graph is run?

1 Like

Thanks Michael, I’m not really sure where or how to implement the remember nodes if this is the solution. I’ve highlighted my inputs, outputs and desired preview geometry below.

My script essentially has two Revit inputs, a property line and a generic model for site context. From what I can see, if these are set to ‘is input’, they appear in the UI for the study. I’ve tried connecting them to remember nodes anyway, but doesn’t seem to make a difference.

My inputs are the width/depth of a building shape and the UV position in the property as a surface. The outputs/goals are a yield based on some vector intersections with the site (maximize) at each level and the height of the building (minimize).

If you can see where I need to add the remember nodes to make it work in the study feel free to let me know - I’m wondering if maybe it’s the gen design tool itself, as other studies such as the desk layout tool are having the same issues.

I did a reinstall, but will try a full uninstall/reinstall to try and ‘wipe’ the settings to OOTB just in case. Wouldn’t be the first time this is a solution to an Autodesk program issue if so…

I can see someone else had the same issues here, but no solution yet;

Edit: No luck on the reinstall.

the remember nodes look like they are in the right spots to me, have you tried exporting it again now that those nodes are in place?

They will record the geometrical data from the revit element so the graph can be run without needing to query revit over and over.

If other built in samples are also having trouble that seems like something else going on though.

1 Like

Indeed, no luck. I’m downloading the installer again just in case there’s been a hotfix to the base msi’s etc. since I last installed (almost on first day of release).

I’ve also joined the forum query seeming I’m having similar issues to that poster, if I can get to the bottom of it I’ll report back here on what was the cause. The studies worked for me a few weeks ago so I’m thinking it’s either a program/windows update intefering, or the generative design service is having issues (not sure if it gets sent to a cloud server?).

There is no cloud server in generative. Can you provide the logs from your generative design instance, and the graph?

I don’t have access to a computer currently Jacob, but Gavin provided the graph at the bottom of his initial post as well as a test model.

2 Likes

Ah! Good catch. I’ll check these but the logs will likely also be required.

1 Like

Thanks Jacob, I assume the Revit log? I can’t find any generative design specific log files so if you know where these are kept feel free to give me a hint and I’ll go exhume them.

I tried making sense of the file and couldn’t seem to spot an indicator. All the events related to the tool seem to be standard, but your eyes probably know what to make of it better than mine!

Based on the fact other studies are having this issue, even the samples I expect it’s an issue beyond my script and could be caused by an add-in conflict or windows update. My list of add-ins are;

(Build 21.0.0.383)

Dynamo 2.5
BIM Interoprability tools
Rhino Inside
Navisworks 21 external tools
DB Link
ETransmit
FormIt converter
Quantification tools

I tried running without Rhino Inside, and also tried the ‘3 box massing’ sample which doesn’t rely on any Revit based elements. No luck, and same issues.

journal.0002.txt (204.5 KB)

I was referring to the generative design and Dynamo logs which are located in your app data folder. i’ll confirm tomorrow.

Most of the time when I have dug into this it’s been a result of the graph not working in the environment which it’s trying to be run in (ie: currently the workspace layout needs a door in the room to calculate any results). It could also be due to a certificate issue which I believe there is a horrid coming for.

When do you present?

1 Like

Ah, found it. You’re right - it’s giving warnings about certificate signings and ultimately failing to load the generative design package when it runs, this might be it.

It looks like the script is trying to load packages from both the Dynamo 2.5 packages folder, and also another folder, ‘C:\ProgramData\Autodesk\RVT 2021\Dynamo\2.5\packages\GenerativeDesignRevit’. I’ll try alternating the contents of these folders and see if I can make sense of where it expects/needs the package to be so that it doesn’t freak out like it is currently.

I present on Thursday night AET. I’ll be moreso comparing differences rather than declaring victors between Grasshopper/Dynamo as there are many factors to warrant the use of both from a cultural/ease of use perspective beyond speed and performance.

dynamoLog_d0729314-6272-46b0-a341-5ca858c96049.txt (20.7 KB)

I’ll reach out tomorrow (3am in my current location) with instructions on how to jury-rig your system for that issue (if it’s the only problem you’ll be up and running) until the patch is out (should be soon but I want you to be able to experiment and play as much as possible before the webinar), but know that this will require manually reversing after the patch is released.

1 Like

Thanks Jacob, much appreciated!

1 Like

And as an aside: the victors in this ‘contest’ will be the offices who put this new generation of tools (Galapagos or Generative Design or whatever other tool we want to discuss) into use. Once an office has their toolset built and staff trained on how to tweak the generation algorithms all of the time saved goes into something else. By eliminating that early stage guesswork and countless hours of manual design iterations which are eventually thrown out entirely, designers can get onto spending time with loved ones, doing a higher volume of projects, or increasing quality on the work they already produce.

I’d like to think that the first option will win out, but something tells me the corner offices will push for option 2 or 3. One can hope that somewhere that won’t be the case.

2 Likes

My thoughts exactly - it’s the process that determines the result rather than the tool. Galapagos is proving to be much faster, but requires some setup from the Revit side to generate a study that could be defined in Dynamo.

Should we get this to work, I’d be more than happy to clean up/annotate my script as a sample for the tool also, it’s probably a good example of a feasibility task where this type of workflow really shines most.

1 Like

Hi Gavin,
Sorry for the trouble. We just released an update to our Generative Design in Revit tool. Should be a quick install. Could you try it and let us know if you’re still having trouble? You should be able to find
Generative Design v21.5.10 for Revit 2021 at https://manage.autodesk.com/cep/#products-services/updates.
Many thanks,
Lilli

2 Likes

Thanks Lilli, no problems. This patch unfortunately yielded the same result, the solution it turned out was a bit odd - I had to copy the generative design package folder from the R2021 folder in place of the dependencies folder generated for the study. Something in the migration of this seemed to prevent the study from working, even when I overwrite my appdata Generative Design package prior.

I’ve made a demo video of the final outcome here if anyone wants to learn more about the tool and how it works. I’ll make proper demo videos on my channel at a later date however;

3 Likes

hi guys, i’m having the same problem even though i installed the latest version of Generative Design, can anyone help me ?

Can you post your graph?

hi Jacob, I figured the preview was available only after I put a Data Remember node for the final Geometry. But another issue is it seems to be the only variation there was, when I ran the Study in Revit all the variations kinda looked the same, probably something else was wrong with my graph, hope you can have a look as well

Thank you for your support

test2.dyn (113 KB)