Stuck in metric


#1

2015_0216 Units-01 I seem to be stuck in metric units. Any Revit item that I create in dynamo is scaled up by 3.28 feet in the Revit interface. I would like to avoid using a conversion factor for all of my parameters.

 

 

 

 


#2

Currently all of the inputs appear to remain this way. I’ve went through the process of building in conversions and am worried for when it changes.

 

Ian Keough mentioned that this will change very soon the other day.

https://twitter.com/ikeough/status/563089297356894208

 


#3

Since version 0.7, Dynamo’s internal units are always meters. The option you selected is used purely for displaying the units. As John said, the Dynamo team are working on an improved solution.

The display option only affects the “Length From String” node. Another option is to use the “Length.FromFeet” node, which converts doubles to their foot value, instead of their meter value.

Do keep in mind that these nodes give you a length and not a number. If you need to use these lengths with geometry nodes, you’ll need to strip them of their units with the “SIUnit.Value” node.

Hope that clears things up.

2015-02-17_135905

 


#4

Very helpful, thanks!


#5

Hey Dimitar thanks this is prob the clearest explanation of where Dynamo’s at with its wiggity wiggity wack units problem.

I’ve been looking into the dual problem of converting to imperial and stripping the unit string suffix out of the result.

SIUnit.Value seems to only work when stripping default metric lengths but I found out from Sol Amour via Andreas that you can use a Formula node and pass the lengths through an X variable. This does not work with a Code Block - only with a Formula node. Image below.

If anyone has any further tips’n’tricks let us know. We eagerly anticipate Ian’s promised Dynamo fix or the fall of the imperial system, whichever comes first.

imperialDynamo


#6

We’re working on it. And we are sorry for any pain required during the upgrade process. We do our best to list the points you should pay attention to when upgrading between release versions of Dynamo. You’ll find those details in the release notes and in the customary blog post.

Here’s what to get ready for:

For the next release, Dynamo will effectively be unitless–no Imperial or metric, Ringley–and Dynamo will be smart about how it reads units from your Revit document… so smart, in fact, that it will read the number that you see.

3 degrees becomes 3.
3 lb*ft becomes 3.
3 mm becomes 3.
etc.


#7

55048409


#8

I’m having issues with units. I’m trying to set a parameter value to 0.5m. But it is coming in as 152. It is converting it to imperial. How do I fix this and why is this the case? This seems to be a new bug in the latest build. I’m using version 0.7.5.3566. Dynamo team please fix!

 

error1

 

 

 

 

 

 

error2

 

 

 

 

Also Colin McCrone - You post about Units back in 29 March 2014, is that still relevant? The images have dropped off which makes the post difficult to understand. http://dynamobim.com/units-in-0-6-3/


#9

The latest daily build already implements the unit fix. You can find it here: http://dynamobuilds.com/
Alternatively if you don’t want to update, you can simply multiply your meter value by 3.28084 to convert it to feet