STL Export

Hi all,
im exporting directly from Dynamo Studio to STL with some surprises :slight_smile:

I’ve hidden any unwanted elements in the view

But i’m still getting the surface in the export

Those ones

This then creates a lot of work for the model makers.
Am i missing anything or it’s the inteded behavior?

Can you share the dyn and a screenshot of your graph? It’s hard to see what the issue is without seeing the graph.

Here’s a dyn file for the same issue I have + STL file.

To refresh, here’s a summary of the issue: the geometry of the nodes which have their “Preview” turned off, still appears in STL file.

Start.dyn (20.4 KB)
model.stl (2.1 MB)

Also the model rotates 90 degrees and becomes horizontal in STL!

Have you tried the ExportMeshes node in the Mesh Toolkit package? Mind you that you have to have the mesh as a MeshToolkitMesh. Either converting a solid/surface with the Mesh.ByGeom node or by using the translation nodes found in the spring nodes package.

the problem with model orientation is caused by different applications treating z as either ‘up’ or ‘out of the screen’

Depending which application you are using- there is often an import option to control this
Below screenshot is Meshmixer

Incidentally, it might be better to start a new post rather than adding on to this old one

Depending how you are exporting to STL i.e. in Dynamo, or from Revit- then the 2 options below will probably work

Option 2 is better if you need usable elements in Revit.