Spring node family instance by geometry


#1

Does someone know why i get null values? I am triying to convert the solid into a revit family.

@Kulkul maybe u know why.

Thanks a lot


Instance Family not showing in Revit project browser
#2

Hi @JAVIER_FQG

If you ignore “null” value. Did it created revit family?

Check your family browser.


#3

No @Kulkul, I have check it…maybe is something wrong in my definition? I use revit 2017 and the last stable version of dynamo


#4

@JAVIER_FQG Could you drop here your files so that we can have closer look at it.


#5

Sorry for the delay. I have try to clean the file as much as possible because it was too heavy but i cant clean it enoguh to upload it here so i put a dropbox link with the revit only with the necessary geometry and also the dynamo definition

Thanks a lot kulkul


#6

could u download the file @Kulkul?


#7

@JAVIER_FQG Yes i am able to download your file. Are you looking to create one solid?


#8

No @Kulkul , what I am triyining to do is create like a topography inside the big volume.

So at the end i will do a wall by face to the volume and the solid generate with dynamo in this case will be like my floor.

i am using a lot your nodes couse i am triying to create some geometry inside those volumes, and for that revit is sometimes very hard to cut complex geometry, dynamo allows me to do it easier but without your node i cant do a section to all of them .

Here u see some geometries where i am triying to do something similar, have those elements inside my big volumes. I know that this is very strange, is for a project in the university jejejeje

Thanks @Kulkul


#9

Look i have try @Kulkul to do the same with this two elements

and i get also null values

I hope this can help


#10

That’s some very interesting shapes. Your template path has spaces. Most likely, the file path node is adding a few “%20” strings in those spaces. Connect the file path to a watch node, to verify.

I’m glad you find my package useful.


#11

Hi @Dimitar_Venkov, you were right. I have spaces in the file path. I have solved it but i continue getting a null value…anyone knows why? maybe the geometry?

Thanks a lot


#12

@Dimitar_Venkov this is very interesting…I have try to copy the node from another Dynamo file that was working properly. Now it works¡¡¡ I have check the file path and doesn´t have the “%20” in the spaces. Now, every file path that i create has those spaces…how can i solve that?? because i want to change the category of the family so i should use another family template, right? Thank you


#13

Hi Javier,

You’ve still got a space in your path between “masa” and “metrica” and the file path node is still broken. You either need to use a String input with the path or use a String.Replace node to replace all the “%20” substrings with " ". Once you do that, everything should work as expected:

and revit:


#14

YOU WERE RIGHT @Dimitar_Venkov

Thanks a lot


#15

Hi all.
I have a question on this topic; is it possible, with this node, to create a family containing multiple objects?
I should already have the answer (see image), but Is there a workaround?


#16

I think Dimitar has explained that in another topic - you can create a family containing multiple objects if they are only surfaces or only solids. You can join solids with Solid.Union even if they are not touching. Same for surfaces using PolySurface.ByjoinedSurfaces. Once they are joined you can import them as one family.


#17

Thank you @viktor_kuzev


#18

Gold star to anyone who figures out how to put multiple geometries, each with their own material assignments, into a single family instance. Two gold stars to whomever figures out how to do this with multiples…


#19

Thank you Viktor. When the geometries come in as one solid however, they all have arrows and handles, but Revit doesn’t let you move the solids individually. Is there a way to explode the geometry (“revit form”) within the edit family environment?


#20

Well if you are running Dynamo in the family itself you can simply import the solids as separate freeform objects - i.e. just not using the solid.union.
If you are working in a project and you create a family from multiple solids it would make more sense to me to change them in dynamo before the import. But if you need to play with them as individual objects afrer the import I guess the simplest way is to open the family and Dynamo inside the family, use it to explode and import the exploded solids and delete the joined solid. Something like this: