Specified argument was out of range of valid values

Hello there,

I have tried to replicate the same script as the link below but the node Views.CreateCallout keeps retrieving the warning “Specified argument was out of range of valid values”. I have changed my geometry scaling settings, but it doesn’t work. Any idea why, please?
I’m using Dynamo 2.3.0 with RVT 2020.2



Can you post your graph and associated inputs so we can see what you’re feeding into the node? Hard to understand why ‘it hurts when I go like this’ if we can’t see what ‘this’ is. :slight_smile:

Hello Jacob,

See below graph. Elements selected are simple lines.


@MarioTJ What archi-lab package version have you got?

This :arrow_down: package version created the callout for me in Revit 2020

While it failed with latest package version 2022.xxx.xxxx.


I downgraded it to that version but the issue still persists. :man_shrugging:


Can you try with a rectangle built at the origin?


Does not seem to be very collaborative. Really appreciate the effort.


I have also tried this but failed miserable. Could it be a units problem between dynamo and revit? That’s the only thing that springs to mine.


Next thing to try: a different view.

Create a plan at elevation 0 and attempt to use the same rectangle here on that. If that works, it may be that the linework you’re sending needs to be pulled onto the view’s plane.


I have tried it this morning in a blank project and it worked. However it doesn’t work in my original project even when changing views as you suggested. Any idea on what can be triggering this behavior?

Many thanks for your answers.


Are the lines on the view’s plane?

This is funny, I made it work in an arch. floor plan but it doesn’t work in a str. floor plan. We are getting closer Jacob.

Might be an API limitation, or an issue with how the node was authored. I suggest reaching out to Konrad by creating an issue for this on the Archi-Lab github: Issues · ksobon/archilab · GitHub

Thanks for your time Jacobs. I will do.

1 Like

It was fixed in the latest version of the package. 2022.210.1520 is the latest at the moment for Revit 2020.

1 Like