Solids created from Dynamo looks good in Dynamo/Civil3D but has errors when opening in e.g. Navisworks

We are modelling some retaining walls and have discovered that the geometry does not look as it should. The procedure we have used is to use alignments/3D polylines from Civil 3D, get points along the curves and create cross sections from the 4 corners using Polycurves.ByPoints and then Solid.ByLoft.
The geometry looks good in civil 3d, also using object viewer, but if we open the dwg in navisworks or when we have exported to ifc and opened the ifc in another program, the geometry seems ‘off’. This is just one of different examples.
We have tried different geometry scaling, lofted with nurbscurves as guidecurves and so on, but nothing seems to be working…
It can even look as bad as what I have put as ‘Worst case’ even though we only use 4 corner points to create the cross sections we loft.
Attached are comparisons and a screenshot of the Dynamo script. Since I’m a new user I can’t seem to upload the .dwg and .dyn file yet.

Does anybody have an idea of how this can be solved?

2 Likes

I’ve actually seen this the other way before…the solids look funky in Dynamo and Civil 3D but then fine everywhere else. So this is interesting. I’m wondering what the file reader settings are in Navisworks?

Also, it would be weird if this mattered, but is there a particular reason why you’re outputting the solid into every block in the drawing instead of just model space?

2 Likes

I would expect the same behavior. I wonder if I’d get the same results on my end. I imagine it isnt a dynamo issue since the output is okay in C3D/Dynamo.

1 Like

No, no particular reason, I based the script of another example so that’s why I’ve used all the blocks.
but wow, thanks for the input! Wierdly I had not thought about the file reader options. I just increased the faceting factor to 10 instead of the default 1 and it looks better already! :slight_smile:
However, that does not explain the ‘worst case’ where I have imported an ifc in Solibri, but I should check those settings as well…

1 Like

This is a Navisworks problem probably caused by objects modelled a very long way from the origin, possibly also depends on units as well
Basically- Navisworks can’t cope with very big numbers

Depending how your model is set up- try getting everything closer to the world origin- often, a local origin is truncated to the nearest round number- say your model is 6328945942m from origin in X direction, you would subtract 600000000
Doing this, then transforming in Navisworks (adding back the 600000000) seems to work

4 Likes

Thank you for your reply!
I thought first that it was a Dynamo <-> Civil 3D problem, but now I am wondering if it is an IFC Export problem.
Appending the DWG with an increased faceting factor seems to work well, but our disciplines are delivering IFC models, and increasing the faceting factor in Navisworks when reading the IFC file did not seem to work.
Navisworks does not seem to be the issue as the IFC file looks the same in other Model viewers as well (e.g. Solibri and Simple BIM). I have also tried to move the whole model to 0,0,0 in Civil 3D without it making a difference. When exporting from Civil3D to IFC, I did not find many options on how to adjust the settings…

If anybody have time or any interest to look at the files I’ll attach below, it will be greatly appreciated!


ExampleToForum.dyn (136.4 KB)
ExampleToForum.dwg (1.4 MB)

This is a stretch, but worth a try: under the IFC file reader settings in Navisworks, can you uncheck “Revit IFC”?

Thank you for your suggestion, but I have already tried that and it does not seem to make a difference unfortunately :frowning:

If its an IFC Export problem, what about trying the Civil 3D IFC 4.3 Import/Export Extension Alpha from the infrastructure futures portal ? Just a thought looking for alternatives. Welcome to our Feedback Community

1 Like

oh well, there goes my theory…

Revit does have a number of options for IFC export- such as geometry precision detail, but I think Civil3D is quite limited.

The CAD file looks ok to me, although it is quite a strange bit of geometry

Have you tried the NWC exporter from Civil3D?- even you need in IFC format it might help isolate the problem

Andrew

In my experience the issue with solid distortion is not because the solid is located in high coordinates, it is because the solid is created in high coordinates!
Try creating the solid near the origin then moving it to its true location in high coordinates.
This has worked for me in the past by appending the dwg in Navisworks and link CAD in Revit but I never tried the IFC option.
As an example, I usually create pipe network solid in dynamo by:

  1. Getting the pipe geometry in Dynamo
  2. Transforming the geometry to Dynamo origin
  3. Create AutoCAD solid at drawing origin
  4. Then use the transform node in the AutoCAD shelf to move the solid back to correct location in AutoCAD
    (The trick is to create the solids in AutoCAD at the origin first!)
    Hope this helps,
5 Likes