Setup Photometric Web File Issue

It is not working in 2017, either

That a good clue. It’s working for me, see here:

I have no more idea on this issue…

Provide please screenshot from the script, please. Because I’m not sure what are you feeding for element in Set Parameter node. I’m feeding the duplicated Family Type because there is no actual elements of this family type.

It’s exactly the script I sent in post 4, I didn’t change anything

So this is different for what am I aimning for. Because in the case I’ve explained and in the file provided, there is no actual elements of the “NEW” family types. And the problem is to assign the parmaeter to the Family Type, not to actual instances of this Family Type.

Yes, you’re right. But then, if you are feeding an Element Type output into an Element input, it won’t work

No. You are able to assign parameter to family types - I’ve already done that with ordinary parameters. The problem comes when trying to assign parameter such as Photometric IES File.
I hope someone will have solution for setting up IES file to Family Type.

I found this in the meantime:

Where did you find this method with buildin parameters? (I mean with Dynamo nodes)

I’ve posted the article in previous post.
I used the method with buildin parmaters for setting up the Detail Number parameter for Views on Sheet.

Do you have a link to this (in Dynamo, not the API method) ? Views weren’t already placed on sheets in this method?

The thing with the views is hole new thing. It is theme of different workflow. Please let stay on the topic with the Photometric Web File. I need help on this. I guess I’ve provided as much information as I can. If anyone has any ideas please share.

Sorry but we are loosing our time here. Cheers

Appreciate your help. Hope someone will join the conversation and there will be another suggestions also.
Have a great day!

It’s actually pretty simple list logic problem. In this sample case what would work is simply putting the file path in a list like that:

If it’s not there the Python script inside the node iterates through the actual string of the file path and assigns as parameter the first symbol of the string - in my case: “C”


The search tool is your friend for time saving:

Thank you!

I can’t understand what you have in mind? Viktor give us the solution. As for the search tool, I’ve use it but there was nothing about setting IES file and I didn’t know what is the problem so I created this post where Viktor helped me. I have no idea that the value should be feeded like list, so I could not know for what to search. Whatever, the problem is solved thanks to Viktor

This was your first answer that made me really loose my time here:

What I want to say is that this conversation wasn’t very productive, so there is something to change, such as:

  • use the search tool to try solutions by yourself first (List.Create was an obvious one, not from viktor_kuzev himself)
  • give links to your sources so that people don’t search
  • and in general, be a little less categoric in your answers because it lead to wrong tracks and it’s unpleasant.

This forum is a place to discuss issues. If you wish to address them to someone in particular, it’s still possible to use the @ tool or to send a private message.

Best greetings

@Yna_Db With all of my respect and appreciations to your help, I will share all from my perspective.

I have provided very clean and detailed information about the issue I had.
I’ve provided script, rvt model, additional files, screenshots and link to artice where the process of setting IES file was explained, using the Revit API.

  • I used the search tool with all the information what I’ve got at the time I’ve posted the issue. There was no similar topics or problems at that time.
  • I gave all my sources (links, etc.)
  • I was right about the value format for the parameter - it is really string, what is not right is that it should be in list, which is whole different beer.

I’ve shared all I’ve done on the script and my understandings on the topic.
So if someone have solution - Great - share it! But if not, try different approaches and if you find solution - share it then. But I don’t find writing some posts randomly very productive.
I’ve tried many nodes and workflows before I even post the issue here. I went through all your guesses here before even start the discussion. That is why I didn’t find your posts here very productive like post 2, post 8, post 10, etc … with only some words in them.

If I knew who will respond and solve the issue I would adress it to that praticular person.

Please, don’t be offended of anything I shared here. I understand that you want to help, but all you’ve done, from my point of view was to add more questions to the issue and made it more complicated and distracted all from the main topic.
That is how I see the things. I just wanted to explain my vision. I may be wrong ofcourse.
There will be no more posts here from me. Cheers and hope in the future each of us will have something in mind to make the forum better place. Thank you!

OK, so now, look at this:

The thread I lastly mentioned is the first one. Then this:

Yours is also the first one, but with a mispelling in “builtin”. So you definitly need to improve your communication before evaluating other’s answers. As I said, giving good links to your sources is necessary. Thanks