Set Upper Limit for Spaces

When Dynamo creates spaces from rooms; is it possible to specify the upper limit and limit offset? When creating spaces through traditional means, I will set the upper limit to be the level above and the limit offset to 0’-0". It would be super helpful if Dynamo could take care of this.

Hi @amvincent_heapy_com

Dynamo can take care of almost everything :smile:

1 Like

So as usual, I’m having a problem… :laughing:

Change lacing to longest for “Get Level by Name” node.

1 Like

Awesome, thank you!

Do you think it would be better to run this graph separately from the one I have to create spaces? Or integrate them into one?

@amvincent_heapy_com you can integrate into one.

1 Like

Level is one of these parameters that has more than one reference stored. What i mean is that there are more than 1 parameter called Level. Dynamo is not consistent with that. I bet the node fails because you sometimes get a Level name and sometimes an actual level element. Use built in parameter for this.

1 Like

I get the same Problem,
but I don’t know, what it mean to…
Change the lacing longest for “Get Level by Name” nodes.

?

When I try to extract the Upper Limit from the rooms in the linked model they all return “null”, why is that?

i have the same Problem. You can use the “LunchBox Get Parameter value” Node from the LunchBox Package to extract the Upper Limit Values, BUT it will only return the Value as a String. I consider to extract the Upper Limit indirectly by first extracting the Level of the Room and then searching for the Upper Limit using the Node “Level.LevelAbove” from the Archilad Package

This “Line” in the corner needs to Change. from “I” to “II”… Just right-click the node and some Options will pop-up. In the Options you can Change the Lacing to longest.