Serious Dynamo Speed Problems

Hi all,

I have been working in Dynamo for several months now. Recently, I have been experiencing extreme slow-down of Dynamo, when I open certain graphs. I have been trying to find the cause, but have had no luck so far.

I am using Dynamo 2.0.1, and Revit 2018, and just did a full clean reinstall of revit and dynamo, and deleted all packages. When I try to open my graphs, some are still painfully slow (to the point of being unusable).

Has anyone experienced something similar? I’ve looked through the forum posts and have tried all of the possible solutions, but to no avail.

I’ll upload an example of the problematic graphs (there is a Custom Node definition and a normal .dyn)

ProjectCounter-181014-1930.dyn (137.5 KB)
Val_MullionCounter_181014-1910.dyf (3.8 MB)

Thanks for any help!

did you see your file size?

open a new project with nothing in it
run your graphs (on nothing)
save your graphs
check the file size

I just tried your suggestion.
I opened a new empty Revit file, then a new .dyn, and simply placed my Custom Node:(Val_MullionCounter_181014-1910.dyf) and clicked Run.

The .dyf filesize grew to 7.5 mb!

I am now going to try to create the definition from scratch, unless you have another idea maybe?

Thank you!

Hi @noam.ronen2

I’m sorry i’m still on 1.3x so i can not open your file.
I thought that element bindings in your file was the problem.

@JacobSmall might have another suggestion tho.

Maybe this helps

@noam.ronen2,

I can’t open this at the moment. However, I can say that there are no bindings in the file. From reading the text I could see how the large number of nodes and custom functions at play is, some of which are jumping deep into the thick of things. Some list management may help, or breaking your graph into multiple graphs.

Please post the larger file as well, as that’s an element binding issue I haven’t seen yet. Note that the 7x multiplier will remove a lot of speed from your efforts as explained in the link.

Also, can you please post a screenshot of your .dyn, and a description of what it does? There aren’t many annotations and they don’t give a good view of the overall scope. This may let me (and others) make some progress in this while I travel to work. Zoom in on a node so you can read the text, and use a camera export (button that looks like a camera in the top right corner of the workspace).

Also, does the graph run quickly, just open slow? Speed when opening can be tied to the nodes in your library - more custom zero touch nodes = more dlls to open and unpack at the start.

Hi,

Basically, My main .dyn is a tool to “count” in different ways different elements in the project. The problematic .dyf for example counts the CW Mullions in the project.

So I have the main .dyn, and inside of it I have several custom nodes, each with it’s own function. the only really complex one is the one I posted (the rest are basic selection and math in dynamo).

The whole viewer is slow - from zooming in, to trying to search for new nodes, to File>Save, etc.

Because I deleted all of my packages, nothing works right now, but I can post screenshots.

Another important question: Can I use packages built for 1.3 in a 2.x definition??

This is the problematic .dyf:

And this is the main .dyn:

Thanks a lot for any help!

Do not create Groups and Notes inside a custom node in Dynamo 2.x, it create several duplicates and slow down Dynamo a lot (known issue, https://github.com/DynamoDS/Dynamo/issues/9114)

Depends highly on the package…

Missing nodes will lead to slowness as well.

Some 1.x nodes work in 2.x, but I advise to check which version made the node when you download it. The pkg.jsn file which comes with it will have that info in the ‘engine’ section.

Multiple graphs may be your best bet here. I’ll try and open this tonight but no promises.

Hi All,

I created the custom node from scratch - just copied the image into a .dyf. I didn’t use any notes or groups, and I made sure all nodes were built for Dynamo 2.x.

This seemed to solve the problem!!

Thanks a lot for all of your quick answers.
Love this community!

1 Like

@noam.ronen2 there is a serious bug in custom nodes that use notes or groups - it has been addressed here:
https://github.com/DynamoDS/Dynamo/pull/9165

3 Likes

FYI @JacobSmall

1 Like