Select Model Elements

Hi Guys,

I’ve a small question related to the node “Select Model Elements” and Adaptive Components. If I try to select multiple Adaptive Components and get them into Dynamo using Select Model Elements, nothing is happening. Dynamo says “Run started …” but stays this way and nothing is happening. Does anybody knows this problem??

First check - make sure you don’t have any property box opened (you the ones with type parameters, etc)

Hi Renzoj, I’ve made absolutley sure no property box or anything is openend. I created a Tunnel using Adaptive Components (each element containing 4 adaptive points), however when I’m trying to import them to convert them into solids (Dynamo geometry) it is doing nothing. I think it is strange, since I’m using the most simple way to import native Revit objects.

What do you mean by “nothing is happening”?
Once you have run the definition in your image, try activating the background in Dynamo and zooming out (You can do this by pressing “Ctrl + B”) you will find your geometry floating around somewhere, could be miles away but it should be there.

When you run the above definition, do you get a list of the geometry created from the “Element.Geometry” node? Click the bottom right of the geometry node and a list should drop down or attach a “Watch” node to the geometry node to see the list

Hi Alisder,

If I run the definition manually, Dynamo says: rund started… but thats it, it stays like this. I don’t get any output data in my element.geometry node. The output list gives me a value “null”. Like you proposed, I already tried to zoom out, watch node, run it from my private and work computer and somehow nothing works.

The Adaptive tunnel elements are created itself with a quite big Dynamo file, I also tried to connect place Adaptive Elements.ByPoints to the Element.Geometry in this definition, strangely, the same thing, it doesn’t want to run.

I’m out of ideas here :confounded:

Hi Wouter,

Can you drop here rvt “Family”?

Hi Kulkul,

I’ve uploaded the 5 adaptive Families that I’m using in my model.

BuP_AdaptiveBodenplatte_rectangular.rfa (316 KB)

BuP_Banquette_Right.rfa (304 KB)

BuP_AdaptiveRoof_ridged.rfa (320 KB)

BuP_Banquette_Left.rfa (388 KB)

BuP_AdaptiveWall.rfa (396 KB)

It works for me. I loaded all your families and below is the result. Follow the process.

Works for me too, but it does seem to take a little too long to generate geometry even with just one instance of each family.

However, there doesn’t seem to be a problem with your families. Place your adaptive components in a new sample Revit project and try. If it still doesn’t work, upload that Revit file here.

Hi Kulkul,

thnx for your help!! This is really odd, since I’m doin the exact same. I tried to rebuild it exactly like u, using the revit template of the company where I write my Thesis. (see picture below).

My Workflow:
1 Opened new template (revit 2016)
2 loaded the families and placed them randomly
3 Created new dynamo file
4 drop the 2 nodes on the canvas
5 selected the adaptive components in revit
6 dynamo doesn’t complete run (Select model elements is working, but element geometry gets stuck somehow)

do you have any idea what could be the problem? Maybe reinstall dynamo and revit?

other question, which software did u use to create your gif? could be very usefull for my presentation :wink:

Thnx in advance!!

1 Like

Hi Vikram,

thnx for your time also!!

I’ve rebuilded the same like my last reply to Kulkul with a default metric template. But still getting the same problem.
I’ve uploaded a picture of the result (workflow is the same as with the other try) and the Revit model.
20160623_TestAdaptiveComponents_DefaultTemplate.rvt (1.0 MB)

Try uninstalling Dynamo all the versions if any. Restart your PC. And install latest Dynamo version 1.0. See if that works out for you.

Hi Kulkul,

Sadly uninstalling all Dynamo versions and only reinstall version 1.0 did not helped. I will just reinstall Revit to see if it makes any difference.

Hi Wouter,

See if that helps! What is your system configuration?

Hi Kulkul,

hereby my system configuration. At the moment I am using Revit 2016 as an student licence and Dynamo verion 1.0

Hi Wouter,

The select elements node seems to be working as expected. I suspect that the problem is the “Element.Geometry” node and particularly those two specific instances of your AC. Could you try modeling a simple native element like a slab or a beam, selecting it and extracting its geometry to try and zero down on the possibilities?

Wouter, your using German version. Try installing Revit and Dynamo in english version. See if that helps!

Hi Kulkul & Dimitar , I’ll give it a try and let you know if it works :wink:

Had no problems in generating geometry in Dynamo using your file.
As indicated, the problem probably lies in the Revit and/or Dynamo installation.