Scripts not saving


#1

Hi,

Whenever I open my scripts parts of the code is gone, even though I saved it only minutes earlier. Does anyone know why this happens?


#2

Can you record a screencast of this behavior, and provide what version of the dynamo (and any other software) which you are using?


#3

I was using Revit 2018 and Dynamo 2.0.2. I ended up changig to Revit 2019, that solved it. https://discourse-cdn-sjc1.com/business6/uploads/dynamobim/original/3X/9/6/96078cf1aebf841bdf48ae9a13d970fc26bdb4f0.mp4


#4

@tmdA5HML - Can you please upload the .dyn made by that example? That is indicative of a larger issue, I’m just not sure what.


#5

Of course, the file that I used is attached here.Test.dyn (2.2 KB)


#6

Interestingly enough, all 3 nodes are there on open for me, but in a somewhat scrambled setup compared to what you showed.

Are you seeing any odd messages in the console when you save or open the graph?


#7

That is extremely strange. No, I haven’t seen anything at all. It happened on several scripts and different nodes every time! Are you using Revit 2018 with Dynamo 2.0.2?


#8

Revit anything with Dynamo anything 2.0.

They show up as unresolved in Sandbox too.


#9

I’m also having a similar issue. They work fine in 2019 but in 2018 nodes disappear :confused:


#10

Oddly enough, when I open that same file in 2019 it’s just how I left it. But when opening in 2018.3, I’m missing nodes :confused: I tried to attach the file but since it said I’m a new user I’m not allowed to -_- so if there is another method of sharing just let me know. Thanks.


#11

Update to the latest Revit version and of that doesn’t solve it disable your add-ins


#12

I’m having this same issue, but I can’t use Revit 2019 just yet. Is there another way around this other than disabling add-ins?


#13

if you are using pyRevit, update to the latest version.