'ScheduleView.AddFields' ignores Multiple Fields with Same Name


I have 3 Schedulable fields with the name ‘Manufacturer’, but the node ‘ScheduleView.AddFields’ only adds 1 field to the schedule. Each field have different values.

Is there a way to add all those 3 fields to the schedule? or to select any 1 field as per our need?


Have you tried setting the lacing for the ScheduleView.AddFields node to longest?

Yes, all ‘Lacing’ and ‘Use Levels’ options were tried.

Can you show the data going into the scheduleView input? Guessing @L1 and @L2 is the answer but can’t tell without seeing what is happening.

Also best to confirm that all 3 fields can be manually added to the schedule, as if there is a parameter mapping preventing them from being added (ie: the parameter isn’t applied to one of the categories of the schedule) you might get blocked like this.

Hey @jacob.small Thanks for some valuable insights.

Actually the data going into the scheduleView input is just the selection node of a schedule.

And regarding those 3 fields, yes you are right. Out of them, 1 parameter cannot be added even manually. But I added 2 parameters manually which cannot be added by Dynamo. (Please refer my second screenshot. That’s the thing I need.

Can you post a screenshot with the results where the inputs are both set to level 1, and lacing to longest?

Here are the results.


And I can manually add the another Parameter.

I can’t reproduce, so best to build a simple use case and post the rvt and dyn here. Put a single schedule (and nothing else) in there which shows what you are looking to achieve and a single 3D view with a few elements in it to use to reproduce the issue.

Yeah Sure
Revit.rvt (6.0 MB) Version 2023
Dynamo.dyn (12.9 KB)

1 Like