Not able to add fields into schedule

Hi everyone,

I’m still a new user in Dynamo so pardon for my lack of skills in this area. Part of my script required the project to create schedule for mechanical equipment, electrical equipment and fixtures which the fields should be according to the parameters which i created earlier on.

I’ve created a list of fields which need to be added into the schedule. However, I faced issues such as:
image . I have no clue which part of my script had gone wrong partly due to my lack of knowledge in dynamo and would appreciate the help of all everyone here.

Below attached is the entire creating schedule script image.

I’ve also attached the dropbox link containing my dynamo script.

Thank you all!

I think that you are feeding “strings” (just plain text) into the ScheduleView.AddFields node, but this node needs “ScheduleField” values. I think this will do the trick:

Dynamo Script for HuiMin.dyn (22.1 KB)

Hi Daan,

Thanks for your prompt response! However, still face issue on my script. In my string contain node, it shows the results as all false which I am sure that whats in the list are all in the schedulable fields but i’m not sure why cant detect the words in the list.

And the list generated become as shown below in Revit:

Sorry for my lack of knowledge in using Dynamo, may I check with you understand on what does the code block in your solution perform to?

Try setting the String.Contains node to Cross Lacing:

Hi Daan,

Thank you! I will go take a look and try it out!

Hi @Daan

Currently I’ve managed to add the fields according to your steps. However is is possible to search for will need to fulfill the entire string in an index? As currently, as long as the system detect any words from the index it will add the field. But what I would like to achieve is the both list will need to be exactly the same.

So for example: Equipment type & Description, when I filter by bool will get only equipment type & description and not any other information with the word “equipment”, “type” or “Description” in it.

Thank you!

Try using the == node instead of the string.contains node (still with cross lacing) this will only set to true when the full string is the same

And for the code block explanation (i missed your question) i search for each item in the list if it is true, and if there is even 1 true, it will output true, so now you got a complete list with true and false to filter your schedulefields by

Thank you so much Daan! You have been a great help. Below is the solution:

There is this small doubt which I faced issue such that under my equipment properties - Identity data, the information had been filled up. However, when i generate my schedule, the information did not appear.

I don’t know why that happend, that should not happen :slight_smile:

Hahaha its alright! Thank you so much for your help! Really appreciate it!

1 Like

Can you confirm this is not an issue of differing values? Is your schedule set to itemize all instances or do you have overlapping groups with different values?

Hi Nick,

I just realized that there are duplicated schedulable fields for mechanical equipment. So when uses the previous method, those fields with no information were being selected.

My bad for not checking it through thoroughly. Below is my method of getting the information even though it might be a tedious method.

Thank you so much!

1 Like